Skip to Content
avatar image
Former Member

SUM tool exiting with /usr/sap/S1M/SUM/sdt/../jvm/jre/bin/java cannot execute binary file

Hi Guys,

Im facing an issue I have never experiecing when Upgrading systems

After downloading latest SAPHOSTCTRL 7.21 Patch 26, for RHEL 7,

[SAPHOSTAGENT_721_26]# ./saphostexec -upgrade
Upgrade service
[Thr 139828022568832] Wed Jun  7 09:05:43 2017
[Thr 139828022568832] SAPCryptoPath /usr/sap/hostctrl/exe/libsapcrypto.so
IsUpgradeNecessary: /softsap/SMisc/SAPHOSTAGENT_721_26/saphostexec is newer than /usr/sap/hostctrl/exe/saphostexec
Upgrade saphostexec / saphostcontrol

Check Installation Path ...
saphostexec is already running (pid=28897). Stopping...ok
Copy Executable ...ok
Migrating ...ok
Install SYS-V service ...ok
-> Start /usr/sap/hostctrl/exe/saphostexec pf=/usr/sap/hostctrl/exe/host_profile <-
start hostcontrol using profile /usr/sap/hostctrl/exe/host_profile
ok
[OK] SAPHostExec / SAPHostControl successfully upgraded
Executing: "/usr/sap/hostctrl/exe/SAPCAR" -xvf "./SHADBMETRICSDEF.SAR" -R "/usr/sap/hostctrl/exe/config.d"
SAPCAR: processing archive ./SHADBMETRICSDEF.SAR (version 2.01)
x dbmetric.definition.db4.cimobj
x dbmetric.definition.db6.cimobj
x dbmetric.definition.hdb.cimobj
x dbmetric.definition.mss.cimobj
x dbmetric.definition.ora.cimobj
x dbmetric.definition.sap.cimobj
x dbmetric.definition.siq.cimobj
x dbmetric.definition.syb.cimobj
x dbmetric.definition.tst.cimobj
SAPCAR: 9 file(s) extracted
SAPCAR: rc 0

executing STARTUP confighostagent <SID>

[root@aolxxxxx SUM]# ./STARTUP confighostagent S1M
**** HOST detected as aolxxxxx
**** The root directory to SUM is /usr/sap/S1M/SUM
**** The SUM has been extracted for SAP system S1M as /usr/sap/S1M/SUM
**** SID parameter S1M as points to a valid SAP system
**** Given SID parameter S1M matches calculated SID from SUM path /usr/sap/S1M/SUM
**** The saphostagent command would be /usr/sap/S1M/SUM/sdt/exe/SLProtocol.sh
**** Set root:sapsys as owner of /usr/sap/hostctrl/exe/operations.d and /usr/sap/hostctrl/exe/descriptors.d
**** Set root user and root group as owner of files in /usr/sap/hostctrl/exe/operations.d and /usr/sap/hostctrl/exe/descriptors.d
**** Configuring SUM Abap:  /usr/sap/S1M/SUM/abap/SUMSTART confighostagent RESTARTSHA=no  ****
**** SUM ABAP: https://aolxxxxx:1129/lmsl/sumabap/S1M/doc/sluigui ****
**** SUM benchmark tool: https://aolxxxxx:1129/lmsl/migtool/S1M/doc/sluigui ****
**** SUM Java: https://aolxxxxx:1129/lmsl/sumjava/S1M/index.html ****
**** SUM Dual stack: https://aolxxxxx:1129/lmsl/sumjava/S1M/dual.html ****
**** SUM Observer: https://aolxxxxx:1129/lmsl/sumobserver/S1M/monitor/index.html ****
**** Restarting SAP Host Agent ****

saphostexec is already running (pid=17855). Stopping...-> Start /usr/sap/hostctrl/exe/saphostexec pf=/usr/sap/hostctrl/exe/host_profile <-
start hostcontrol using profile /usr/sap/hostctrl/exe/host_profile
**** SAP Host Agent has been restarted ****
**** You are using SAP Host Agent version: ****
**** hostagent release: 7.21 ****
**** hostagent patch number: 26 ****
**** Please check the central SUM note and its dependent platform specific SUM note ****
**** whether this SAP Host Agent version is sufficient for SUM operation ****
[root@aolxxxxx SUM]#

then accesing via browser to UI, Im getting the following message

Internal Server Error

Operation  [id=0050568BC5DA1EE792EEDE24F8024C08] terminated with errors : 127 () 

description:Start SUMJAVA

/usr/sap/S1M/SUM/sdt/exe/SLProtocol.sh: line 33:

/usr/sap/S1M/SUM/sdt/../jvm/jre/bin/java: cannot execute binary file

/usr/sap/S1M/SUM/sdt/exe/SLProtocol.sh: line 33: 

/usr/sap/S1M/SUM/sdt/../jvm/jre/bin/java: Successexitcode:126

Is it an issue with SLProtocol.sh file?

I have tried to execute that file manually and it also gives the same error message.

Any hint?


Thanks!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jun 09, 2017 at 02:06 AM

    It was due a mismatched version of Linux files which were for anoter arquitecture.

    Fixed after downloading proper files again

    Add comment
    10|10000 characters needed characters exceeded