$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: false, vro: false, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content
avatar image
Former Member

http://localhost:8080/BOE/CMC The requested resource () is not available.

Hi,

After installing Business objects I am having issues opening CMC.

The error message reads "http://localhost:8080/BOE/CMC The requested resource () is not available."

Im also not able to open "http://localhost:8080/BOE/BI" The requested resource () is not available."

Product version: BOE BI 4.0

Product patches installed: None

OS: Win 2008 R2

.NET : 3.5.1 installed

Tomcat 6

Java 7 update 79

Tomcat server is up and running.

The webapps folder in my installation has the following sub folders

docs

host-manager

manager

ROOT

I am able to open the http for apache tomcat https://localhost:8080. This opens the tomcat home page. But when I add the BOE/CMC or BOE/BI, it throws the HTTP status 404 error. type Status report message /BOE/BI description The requested resource is not available.

Also in the following directory I dont have any anything(it is empty)

D:\GCTI\SAP BO\SAP BusinessObjects Enterprise XI 4.0\wdeploy\workdir\tomcat7\deployed_apps

In this directory (D:\GCTI\SAP BO\SAP BusinessObjects Enterprise XI 4.0\wdeploy\workdir)

I have two files :

wdeploy.properties

workfir.properties.

Can you please help me to fix this error.

Appreciate your response.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • Best Answer
    Jun 06, 2017 at 07:42 PM

    sounds like BOE webapps are not deployed to the tomcat.

    You need to use webapplications deployment guide and manually deploy them to your tomcat.

    http://service.sap.com/~sapidp/012002523100016084202015E/xi4sp12_bip_wapd_win_en.pdf

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 07, 2017 at 06:56 PM

    Hi,

    Thanks for the reply

    when I m trying to access the page it is giving me error:

    Error Message - Access denied (R/3)

    What happened?

    You do not have permission to access this Object

    What can you do?

    • Please contact a consulting adminstrative
    • Error code: WEBSMP209-20170607205958-0015
      Error details: 13D1DD9-702/1A053/3162-714A2238-356B03B-11A-13BAE1E-5240C2/2D

      Service Name: SAPIDB

      Service Server: WEBSMP209

      Process-ID: 2376

      Thread-ID: 1148

    Sorry for any inconvenience.
    Your SAP Service Marketplace Team

    Is there a way please to get the pdf.

    Appreciate your help please

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 08, 2017 at 12:37 PM

    Hi

    when I run wdeploy tool I get the following error as attached : "Error: service name BOEXI40Tomcat is not correct. (DEP00136)"

    Wdeploy_summary log file:

    java version "1.6.0_75" Java(TM) SE Runtime Environment (build 6.1.066) SAP Java Server VM (build 6.1.066 24.55-b13, May 7 2014 18:40:24 - 61_REL - optU - windows amd64 - 6 - bas2:217766 (mixed mode)) JAVA HOME= D:/GCTI/SAP BO/SAP BusinessObjects Enterprise XI 4.0/win64_x64/sapjvm Version = 4.1 Work_dir = D:/GCTI/SAP BO/SAP BusinessObjects Enterprise XI 4.0/wdeploy//workdir Wdeploy Action = deploy ServerType = tomcat7 Wdeploy COMMAND = wdeploy tomcat7 -Das_dir="D:/GCTI/SAP BO/tomcat/" -Das_instance=localhost -Das_service_name=BOEXI40Tomcat -DAPP=OpenSearch deploy Wdeploy APP = OpenSearch AppSourceDir = D:/GCTI/SAP BO/SAP BusinessObjects Enterprise XI 4.0/warfiles/webapps/OpenSearch Error: service name BOEXI40Tomcat is not correct. (DEP00136)

    I have unchecked Tomcat installed as a windows service and also tried but still facing same error.

    I have removed config.tomcat6 file and tried but still getting same error file .

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 08, 2017 at 01:43 PM

    It appears that the BO installation failed to install Tomcat, or at least failed to install it completely.

    You obviously have an active tomcat installation since you're getting to :8080/. The fact that wdeploy doesn't the see the BOEXI40Tomcat service indicates one of two things:

    • There was already another instance of tomcat present when you installed BO, and that prevented BO from completing the installation, or
    • BO only partially completed the tomcat installation. This seems unlikely, as it would mean that it got as far as installing the Windows service but did not rename it.

    If this is a brand-new installation, I would suggest just uninstalling everything and starting over. But first check for any other installations of tomcat on the system.

    Note that a BO-installed tomcat service will be named "Apache Tomcat for BI 4" in Services. You're only showing part of the screen so I can't tell if it's there or not.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 13, 2017 at 09:28 AM

    hi,

    It would be very helpful if you can help me to fix the SAP BO installation as I explained earlier in previous posts,

    I m still gettinng the error in Wdeploy summary log "Error: service name BOEXI40Tomcat is not correct. (DEP00136)"

    I have tried using wdeploy app to get all the folders in webapp folders under tomcat as I see only these folders :

    The webapps folder in my installation has the following sub folders

    docs

    host-manager

    manager

    ROOT

    I tried to change the tomcat port and and did a re installation of SAP BO server

    but still I dont see folders in the webapps.

    I still get the same error "

    http://localhost:8085/BOE/CMC The requested resource () is not available.

    Can you please help.I would really appreciate it.

    Thanks

    Ajith

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Denis Konovalov

      Hi Denis,

      I 'll contact them and ask them to create an incident.

      genesys is a technology where we use SAP BO to create our reports.

      Thanks

      Ajith.

  • avatar image
    Former Member
    Jul 18, 2017 at 11:52 AM

    Hi All,

    I was able to get the CMC page up by manually copying the webapps folders which are not populated.

    But I m facing an issue:

    The central configuration manager does not have SIA.(SIA is missing)

    I have tried following steps to create SIA:

    1)Launch Central Configuration Manager (CCM).

    2) Click on Add Node. Enter the Node Name and SIA Port (Default 6410). [Node Name must be Unique not even the Node Name given at the time of installation]

    3)Select Add Node with CMS and Default Servers and click Next. Select Start a new temporary CMS and click Next. Enter CMS Port (Default : 6400).

    4)Specify the CMS System Database Data Source Name.

    5)Enter the Cluster Key given at the time of installation when requested and click Next.

    6)Provide CMS Logon parameters and click Next. [Note : Here Username will be Administrator and Password will be Blank i.e. NO Password] Click Finish to start creating the SIA.

    Im getting struck at step 4 ,Im getting the following error as shown

    Im using sql (ODBC) as the database driver as we have MSSQL db.

    Thanks

    Ajith

    Add comment
    10|10000 characters needed characters exceeded

    • we do not support file data sources for CMS DB connections, you need to setup System DSN ODBC connection to your SQL server, then use it.

      Please review Installation Guide one more time for the proper steps , pre-reqs etc..

  • Jul 18, 2017 at 01:30 PM

    Hello Ajith,

    Looks like you have installed your BOBJ without using the Deploy applications options provided within the tool.

    I faced this issue once, so had to uninstall BOBJ and re-install using option Deploy.

    Additonally, you would also need to check system DSN connections which are created for CMS and AUD DB.

    Thanks

    Abhi

    Add comment
    10|10000 characters needed characters exceeded

    • hi Ajith,

      I am not aware of any such process, also I think that would not be wise as SIA is configured during installation.

      If you are doing a new installation, then it should not take long time..

      Thanks

      Abhi