Skip to Content
1

Not able to Login xsa_admin in SAP HANA 2 Express Edition

Jun 06, 2017 at 10:53 AM

1.5k

avatar image

Hello All,

I have Hana Express 2.0 in VMware Workstation 12 Pro. I have been having issues while trying to login as XSA_ADMIN. I am logged in as hxeadm and trying to run following command :

xs login

After inputting the API_URL I get following error :

FAILED: Could not connect to controller on https://hxehost:39030 errno: 111 (Connection refused), error: Connection refused (local port 42814 to address 127.0.0.1 (localhost), remote port 39030 to address 127.0.0.2 (hxehost.localdomain.com))

I tried using:

xs api https://hxehost:39030

I get the same error as mentioned above.

Any help will be useful.

Thanks in advance

error.png (11.0 kB)
10 |10000 characters needed characters left characters exceeded

Is the XSA controller already up and running? After starting HXE it takes some time until it is available. You can check it with the "HDB info" command.

0
Former Member

Hello,

This is more of a question. I was wondering if someone else was able to solve this problem, without using the approach that Frank has mentioned. I too am working with a virtual box which has a hana express setup. I am not able to login to it and am getting the same error as Talha. Any pointers will be appreciated.

Regards,

Chetan

0

Hi Chetan,

There is no magic bullet here. As Florian mentioned it takes some time for the whole XSA infrastructure to come up. When you run SAP HANA, express edition (server+applications) on a cloud platform with a virtual machine sized at 32 GB with 4 vCPU cores, as recommended, it takes about 8 minutes for all applications to be up and running (until that time, you will get 503 service not available messages). As a comparison, on the same machine, it takes 30 seconds for all HANA database services to be up.

After starting the VM, you can open a terminal session, connect as hxeadm and run command

top

You will observe that nameserver and java processes consume CPU for quite some time. When cpu is at 2-3% or so for 10 seconds or more, you can safely assume that all processes are up.

Unless you run the VM locally on a NUC, as suggested by Frank, it might take even longer for all XSA applications to come up if you are using a laptop with 16 GB and 12 GB allocated to the VM (for example). If you allocate less then 12 GB, some applications might not start at all.

The controller is one of the first to be up, so you should not have to wait for 10 minutes or so. However, connection refused often is an indication that the controller is not ready yet.

1

Hello

When I got that error, allocated memory to my VM was just 10GB (approx). Now I have assigned 25GB and its working fine.

As Denys explained it takes time. You just have to wait.

Regards

Talha

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Frank Schuler
Jun 06, 2017 at 11:53 AM
0

Hello Talha,

This looks as if there was something wrong with your network configuration. If you like please have a look at this blog of mine that describes an alternative approach:

Tips & tricks for an optimized HANA 2.0, express edition installation on an Intel 6th generation NUC

Best regards

Frank

Share
10 |10000 characters needed characters left characters exceeded