Skip to Content
0

Lost line text in Text field overlapping bottom page margin

Jun 06, 2017 at 06:32 AM

48

avatar image
Former Member

Hi all,

I have a problem in a report: a near bottom margin text field lost 2 of 5 text lines, (normally these last 2 lines would go to next page.)

It is a windows form application, net 4.0, tested with crystal reports for visual studio sp 18, 19, 20.

In Crystal report viewer, on printed pages, in pdf export 2 lines of text "disappear".

exporting to .rpt, all 5 lines are visible, (but when printing from crystal report 2013 the issue come up again)

the text is:

MADE IN ITALY
All charges in connection with transfer of
payment as well as other banking charges (NOT "SHA"),
including banker's commission, are to be covered
by the buyer.

link to report: https://1drv.ms/u/s!AoBD0PRaz8XftCI4vBdPuwJFqlMU

Thank You

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
avatar image
Former Member Jun 10, 2017 at 06:50 AM
0

Hi Don, thanks for Your reponse,

link to xml data file: https://1drv.ms/u/s!AoBD0PRaz8XftCMSlMWMSsPQfBND

however I want You know this: if I insert a blank record between last article and truncated field, all goes right !

see this new report: https://1drv.ms/u/s!AoBD0PRaz8XftCTHeXw14MzpgeNz

the first 2 line of text remain in first page and the last 3 go to second page.

thank You

Enzo

Share
10 |10000 characters needed characters left characters exceeded
Don Williams
Jun 07, 2017 at 08:42 PM
0

Hi Enzo,

Thanks for the report, I see the same thing using SP 21 ( beta )

I found one error in the formula linking field to the subreport:

Engine Subreport count: 1

Subreport Formula Field Count: 1
Subreport Name: TaglieColoriDoc.rpt - Subreport1

Formula: @ColoreDescr : Used: 1 times'End'

Error in formula :
Error in formula ~:
'if {?Pm-@DescrInLingua}= true then
'
This field name is not known.
Details: errorKind

Formula Text: if {?Pm-@DescrInLingua}= true then
if {TaglieColori.DescColoreLingua}<>"" then
{TaglieColori.DescColoreLingua}
else
{TaglieColori.DescColore}
else
{TaglieColori.DescColore}

I'll keep looking, I don't know why. Maybe something with the subreport, try fixing the link and see if that helps?

DOn

Share
10 |10000 characters needed characters left characters exceeded
Don Williams
Jun 07, 2017 at 10:12 PM
0

Hi Enzo,

I see the same issue in CR Designer, I see the data but when exporting to PDF the last few lines are also cut off.

Patrick ( CR Resource Rep ) is going to go over the report and try to figure out why....

Thanks again

Don

Share
10 |10000 characters needed characters left characters exceeded
Don Williams
Jun 08, 2017 at 01:41 PM
0

The odd parts is I see the same text being chopped off in both CR Designer and my test app. When I print the report to a network UNIVERSAL.Driver it comes out correct....

Is it possible to get the XML data source for this report? We can't refresh it and there appears to be missing data also.

Thanks again

Don

Share
10 |10000 characters needed characters left characters exceeded