Skip to Content
0

flat file - expected number of columns issue

Jun 05, 2017 at 12:21 PM

45

avatar image
Former Member

Hi,
I created source which use flat files (csv), this source takes all .csv files (Country_XX.csv, Country_YY.csv) from folder.

In flat file connection in file name I typed: Country*.csv and choosed delimeters '|' .
Every file has 15 columns.

When I run process first file is inserted correctly and then when process starts read second file I got error:
"The expected number of columns was <15> while the number of columns actually read was <1>. Check the input file for errors or verify the schema specification for the file format. The number of rows processed was <1>."

When I run process only for one file (first - Country_XX.csv, second Country_YY.csv) it works. So the problem is only when I want to import 2 files in the same time.

I read in this forum a lot of articles, I tried option: Adaptable Schema = 'YES' but in this option from second file I got only one record with value '??????' - what doesn't mean?

My BODS version: SAP Data Services 4.2 Support Pack 2

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Arun Sasi Jun 06, 2017 at 08:45 AM
0

When you open the CSV file in a notepad what delimiter do you see in it? I guess you are using Delimited type of File Format

Try to find the issue with the data in the file. It might be issue with unicode characters due to which the columns are not read properly

Regards

Arun Sasi

Share
10 |10000 characters needed characters left characters exceeded