Skip to Content
0

Hybris Marketing import interest

Jun 04, 2017 at 06:26 PM

156

avatar image
Former Member

Hi All,

I have been trying to import interest data via CSV upload. The templates asks for only 3 values: interest_item, EN,DE. However, when i put "Candy;Candy;Candy" or "INTEREST_1;Candy;Candy", an error message comes up saying "Attribute INTEREST_ITEM in row 1 is mandatory but has not been provided."

can anyone please help me to understand why this happens and how can i import interests?

THANK YOU!!!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

avatar image
Former Member Jun 04, 2017 at 11:53 PM
0

Did you by any chance delete the first couple of lines when creating your file for interest upload?

Like in below example, if you delete the line with the attribute names, it would give you that exact error.

Please select as answer and close this thread if this answers your question.

Wr,

Akil

* Identifier;;First Name;Item of Interest     descriptions of the attributes being uploaded
ID;ID_ORIGIN;NAME_FIRST;INTEREST_ITEM         attribute names
8021001770;SAP_CRM_BUPA;วรินทร;;               actual values that you`re trying to upload
Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Akil,

I am using the template downloaded from "Import data" application. In the interest template, which contains only the following attributes:

INTEREST_ITEM;EN;DE INTEREST_1;First interest;Erstes Interesse INTEREST_2;Second interest;Zweites Interesse

do you mean that this template is not correct and i should update this template?

0
Former Member
Former Member

If you upload like following (German and DE in your case) it should upload. Did you enable German or the other language you want to upload in scoping?

* Item of Interest;English;Thai
INTEREST_ITEM;EN;TH
000000000000000001;PRINTRONIX P7200HD;PRINTRONIX P7200HD
000000001884055012;BESCO GREASE(L3).5KG;จารบีเบสโก้ L3 (0.5กิโล)
000000005867604330;BEDLINER OVERRAIL CREW;พื้นปูกระบะOVERRAIL CREW

0
avatar image
Former Member
Jun 21, 2017 at 01:02 PM
0

Hi Ha Gao,

if you fill looks like

INTEREST_ITEM;EN;DE
INTEREST_1;First interest;Erstes Interesse
INTEREST_2;Second interest;Zweites Interess

then the upload should work, just tested it in our system.

Please take care that the format of the files is really a CSV. In Excel, you can choose eg. CSV (MS-DOS) as target format.
If there are line feeds or other invisible control symbols contained in the file, the parser might have issues even if the content looks fine.

Best regards

Stefan

Share
10 |10000 characters needed characters left characters exceeded
Krishnendu Laha Jun 21, 2017 at 04:31 PM
0

hello,

when you save the CSV file first time, the Excel formulates the record in a pecuilar way and generally composed into frist column. Please open the Excel -> select the column -> and click Data -> Text in Columns -> Separate using semicolon (;).

Save the file and try to upload again.

Thanks,

Krish

Share
10 |10000 characters needed characters left characters exceeded