Skip to Content
0

Web-dispatcher Mapping to ECC system over an HTTPS port

Jun 12, 2017 at 11:38 AM

180

avatar image
Former Member

We are facing Major problems in the Inbound connection, From C4C to ECC.

We are trying to get the following

C4C->HCI->Firewall->WebDispatcher->ECC, over an HTTPS port and the authentication method is SSL but we are unable to do so.

Currently we have made the connection as

C4C->HCI->Firewall->ECC over an HTTP but we want to make it as https

..Following is the profile

SAPSYSTEMNAME = WPD

SAPSYSTEM = 00

INSTANCE_NAME = W00

DIR_CT_RUN = $(DIR_EXE_ROOT)/$(OS_UNICODE)/hpia64

DIR_EXECUTABLE = $(DIR_CT_RUN)

DIR_PROFILE = $(DIR_INSTALL)/profile

_PF = $(DIR_PROFILE)/WPD_W00_AWDQA

SETENV_00 = DIR_LIBRARY=$(DIR_LIBRARY)

SETENV_01 = LD_LIBRARY_PATH=$(DIR_LIBRARY):%(LD_LIBRARY_PATH)

SETENV_02 = SHLIB_PATH=$(DIR_LIBRARY):%(SHLIB_PATH)

SETENV_03 = LIBPATH=$(DIR_LIBRARY):%(LIBPATH)

SETENV_04 = PATH=$(DIR_EXECUTABLE):%(PATH)

#-----------------------------------------------------------------------

# Accesssability of Message Server

#-----------------------------------------------------------------------

#-----------------------------------------------------------------------

# Configuration for medium scenario

#-----------------------------------------------------------------------....

#-----------------------------------------------------------------------

# SAP Web Dispatcher Ports

#-----------------------------------------------------------------------

icm/server_port_0 = PROT=HTTP,PORT=8100

#icm/server_port_1 = PROT=HTTP,PORT=8101

#icm/server_port_2 = PROT=HTTP,PORT=8102

#icm/server_port_3 = PROT=HTTP,PORT=8103

icm/server_port_1 = PROT=HTTP,PORT=8200

icm/server_port_3 = PROT=HTTPS,PORT=44300

#-----------------------------------------------------------------------

# Start webdispatcher

#-----------------------------------------------------------------------

_WD = wd.sap$(SAPSYSTEMNAME)_$(INSTANCE_NAME)

Execute_00 = local rm -f $(_WD)

Execute_01 = local ln -s -f $(DIR_EXECUTABLE)/sapwebdisp$(FT_EXE) $(_WD)

Start_Program_00 = local $(_WD) pf=$(_PF)

SETENV_05 = SECUDIR=$(DIR_INSTANCE)/sec

ssl/ssl_lib = $(DIR_EXECUTABLE)$(DIR_SEP)$(FT_DLL_PREFIX)sapcrypto$(FT_DLL)

sec/libsapsecu = $(ssl/ssl_lib)

ssf/ssfapi_lib = $(ssl/ssl_lib)

#-----------------------------------------------------------------------

wdisp/system_conflict_resolution = 2

wdisp/system_0 = SID=SIW,MSHOST=hostname1,MSPORT=8111

wdisp/system_1 = SID=SIU,MSHOST=hostname2,MSPORT=8100

#wdisp/system_1 = SID=SFD,MSHOST=hostname3,MSPORT=8100

wdisp/system_2 = SID=SBH,MSHOST=hostname4,MSPORT=8101

wdisp/system_3 = SID=EXT,EXTSRV=http://hostname:50000,SRCSRV=*:8200

10 |10000 characters needed characters left characters exceeded

The tag "Using SAP.com" is specifically intended for questions about this site itself. You'll likely get faster answers to your questions if you use a more appropriate tag. For more information about tags, please read this - https://www.sap.com/community/about/using-tags.html.

Steve.

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Isaias Freitas
Jun 14, 2017 at 06:31 PM
0

Hello Sudipta,

The Web Dispatcher profile shows 4 systems being configured.

Which is the ECC system? SIW, SIU or SBH?

And if that is the complete profile, I would say that the configuration is incomplete.

You should change the parameter "wdisp/system_conflict_resolution" to 1 and adjust the "wdisp/system_X" parameters, using appropriate system selection criteria.

This WIKI page can help you with that.

This is another WIKI page that might help you with the setup of this landscape as well.

Regards,

Isaías

Share
10 |10000 characters needed characters left characters exceeded