Skip to Content
0

TLS 1.2 support for visual studio download version 2013 at any Support Pack

Jun 02, 2017 at 09:07 PM

342

avatar image
Former Member

I have the 64bit.msi for Support Pack 20 (v.13.0.20.2399) download from the MSI column that we got from the following website that we use: https://wiki.scn.sap.com/wiki/display/BOBJ/Crystal+Reports%2C+Developer+for+Visual+Studio+Downloads

We disabled a server with TLS 1.0 and the reports will not run or connect to that DB any longer with Support Pack 17 we had then. We got on a chat with one of your reps last week and asked what version of 2013 support packs support TLS 1.2, as that seems to be the workaround for the TLS 1.0 and they said the latest one, which is SP20. That version has the same issue, we downloaded it and then tested the disabling of TLS 1.0 and it failed to work. We made sure that 1.2 version was installed and active on the server and cannot discover any other thing that might affect the operation. Does not appear TLS 1.2 is supported at any Support Pack here.

What version of Visual Studio will have support for TLS 1.2? We need to know what version we will need to move to before we disable TLS 1.0 on the server. Thanks

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Don Williams
Apr 25 at 04:21 PM
0

Search for this KBA -

2269180 - Disabling TLS 1.0 may cause Crystal Reports Designer and .NET application to fail to connect to your MS SQL Server Database 2012/2014

( clicking on link will not work for you, use Google to search for it )

TLS 1.2 is not a CR Issue, it's all client based, the DB client needs to support TLS 1.2

Don

Share
10 |10000 characters needed characters left characters exceeded