Skip to Content

Issue with Masking numbers in SAP GLM Labels

Hi All,

we are facing an issue after EHP7 and WWI SP43 Upgrade that when we use numerical output with Masking - the value gets formatted with ',' (comma /dot) thousand separators.

e.g Delivery No output using Symbol <02GCG_VBELN(N:"ZZ99999999")> is getting outputted as 11,111,111 rather than 11111111.


I checked the decimal format of the generation variant header- but that is not affecting it.

P.S:

1. System instance which is not upgraded with EHP7 & WWI SP43 works perfectly with the same symbol & Data.

2. Cus. Ord.No. in above screenshot is without any masking- works correctly/

Can anyone guide please.

Regards,

Gaurish

capture.jpg (16.3 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jun 05, 2017 at 08:02 PM

    Hi All,

    This is is resolved now.

    Cause: Implementation of SAP Note 1830050

    Resolution: 1939941 - Exceptions for symbols with numeric masks.

    Side-effect notes: 2322373 - Exceptions for symbols with numeric masks

    Regards,

    Gaurish

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 03, 2017 at 12:44 PM

    Dear Gaurish

    generate own WWI template and own generation variant. INclude only this symbol (whcih does not work) use the same formatting etc. like in original one in the WWI layout. Try again. Check the value file generated to make sure that database is passing on the correct value, but issue come up in WWI (this is assumption from my side)

    C.B.

    PS: Assumption: problem is with WWI SP43 not with ENHPack7: You can anlyse as well value file now for "wrong" report ; may be show content of value file here.

    Add comment
    10|10000 characters needed characters exceeded