Skip to Content
0

* -10709: Connection failed (RTE:[89006] System call 'connect' failed, rc=111

Jun 01, 2017 at 09:53 PM

5k

avatar image
Former Member

I just installed the SAP HANA virtual machine on VMWare. However, when I try to connect using hdbsql I'm getting this error:

hxeadm@hxehost:/usr/sap/HXE/HDB90> hdbsql

Welcome to the SAP HANA Database interactive terminal.

Type: \h for help with commands
\q to quit

hdbsql=> \c
Username: SYSTEM
Password:
* -10709: Connection failed (RTE:[89006] System call 'connect' failed, rc=111:Connection refused (localhost:30015))

Here are some doubts I have

1. What should the password be in this case? Should this be the default database password I set when I first started up the VM?

2. Do I need to enable some ports on the firewall? If so how should I do it?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Denys van Kempen
Mar 15 at 08:41 AM
1

Hi Kevin,

You are not telling hdbsql where to connect to, so it defaults to <localhost> with the first instance number possible: 00. This results in SQL port 30015. However, SAP HANA, express edition uses instance number 90, so the port that HANA listens to for SQL connection is 39015.

The SAP HANA interactive terminal, hdbsql, reports that the connection was refused but a clearer message would have been: there is no HANA SQL interface listening to port 30015.

See my blog post

So the connect strings above will only work if you execute them on the SAP HANA server with instance number 00. For the other 99.99% of the cases, you will need to provide the “node” information with -n or \n (or just the instance number when on “localhost”). In case of multitenant databases, add -d or \d with database name. hdbadm> hdbsql -u DBA -p P@$w0rd! -n <host>[:<port>] -i <instance number> or hdbsql> \c -u DBA -p P@$w0rd! \n <host>[:<port>] \i <instance number>

Does this answer your question?

Regards,

Denys / SAP HANA Academy

Subscribe to our YouTube Channel
Join us on LinkedIn
Follow us on Twitter
Github code samples
Facebook

Share
10 |10000 characters needed characters left characters exceeded
Annie Niangneihoi
Jun 02, 2017 at 08:55 PM
0

Hi Kevin,

To answer your questions, this step-by-step tutorial would be helpful: https://www.sap.com/developer/tutorials/hxe-ua-getting-started-vm.html

  1. Your SYSTEM password should be the HANA database master password you set up when you first configured your installation (see step 3)
  2. See Step 4. It depends on your type of installation and the proxy settings you configure.

Hope this helps!
- Annie

Share
10 |10000 characters needed characters left characters exceeded
Hakan Haslaman
Jun 06, 2017 at 06:05 AM
0

You can check the SAP Note#2316463 to answer your port question.
If this not fix your issue, please further proceed with troubleshooting the error -10709 SAP Note#2213725.

Share
10 |10000 characters needed characters left characters exceeded