Skip to Content
0

Search help selected result not returned to UI field (Selected row not returned)

Jun 01, 2017 at 05:55 PM

300

avatar image
Former Member

Hi All,

I have created an elementary search help. The search results are as expected.

When I select a row from the results, the value is not returned into my UI field.

Am i missing somthing here? I have written the call_control-step 'SELECT' to read the values from DB based on user input. I am using the F4UT_RESULTS_MAP to map the results. No other steps have been programmed. Please let me know if i have missed something here.

Thanks.

10 |10000 characters needed characters left characters exceeded

Probably you didn't link correctly the screen field to the search help exporting parameter. There are so many ways, it's difficult to tell you all possible issues and solutions. What did you do exactly?

0
Former Member

Please find the pic above which shows that I have provided the search help name in the SPRO settings.

Im not sure about linking the selected value(search help export param) to the UI field.

Thanks.

1
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Raymond Giuseppi
Jun 02, 2017 at 06:18 AM
1

Test the search help from SE11, is the exported parameter(s) defined in the parameter list of the search help correctly returned, does it carry the correct data element(s) expected by SPRO?

Show 4 Share
10 |10000 characters needed characters left characters exceeded
Former Member

SPRO is just having the configuration where I don't have to give a parameter with a data element.

I have to just give a description.

Hence it is not very clear what it expects?

From the functionality it should have the Partner ID in the UI field and I have marked the Partner ID as exporting parameter in the search help.

0

Does the test with SE11 return a value?

0
Former Member

Hi Raymond,

My search help has an exit where an RFC module is called.

Im executing the RFC module in the call-control step "SELECT" which executes the module in ECC and reads the data.

The search help returns the results when called through the webdynpro screen, but the selected value is not transferred to the screen field.

When i call it in SE11 the RFC module is not returning any results.

Im not sure what is wrong in this situation.

When i execute the RFC FM module in the ECC system(locally) then the results are returned.

Thanks for your help.

0

You could try some debug when testing with SE11, also insure no authorization is missing (e.g. S_RFC) when executing in RFC mode.

1
avatar image
Former Member Jun 02, 2017 at 05:55 AM
-1

Hi Sandra,

This is a custom partner field which gets added through the SPRO settings. In the SAP SRM we have an option to add custom partner functions to the document at item level.

I create the fields using the steps in the link: <<https://wiki.scn.sap.com/wiki/display/SRM/Inserting+a+new+partner+function+in+shopping+cart>>

In the Partner Determination Procedure we have an option to add the search help and I have done the same.

I am not sure how the result can be mapped back.

Thanks a lot.

Share
10 |10000 characters needed characters left characters exceeded
Sandra Rossi Jun 02, 2017 at 06:19 AM
0

I don't know this search help, so here are a few things to check in the search help:

  • Create a simple search help, without search help exit, to make sure the link between the search help field and the UI field works.
  • Especially, make sure the data element is the same between the search help field and the UI field; and you must pay attention to linking the parameters between elementary search help and collective search help if any.

If you need more assistance, please provide details about your search help(s) and your UI field (data element, how is it linked to the search help).

Share
10 |10000 characters needed characters left characters exceeded