Skip to Content
avatar image
Former Member

com.sap.aii.af.ra.ms.api.RecoverableException

hello friends,

iam doing a file to file scenario, file adapter picks the file in the message monitoring iam getting this error

Transmitting the message to endpoint http://sapxidev:50000/sap/xi/engine?type=entry using connection AFW failed, due to: com.sap.aii.af.ra.ms.api.RecoverableException: Received HTTP response code 404 : Not Found.

I checked the below weblog.

SMICM --> HTTP port # 8000

/people/krishna.moorthyp/blog/2006/07/23/http-errors-in-xi

on thing i observerd in the weblog

"If the error is because of integration server when using Proxy communications then check these. i.e SXMB_ADM->Integration Engine Configuration->Corresponding Integration Server enrty should be dest://<Http Integration server-Destination> Where < Http Integration server -Destination > is the RFC destination (SM59) of type HTTP connection (type H) to the Integration Server. In this case, host name, port, and path prefix are saved in the RFC destination".

In Corresponding Integration server there is no entry in the system. ( if this is the problem how to change it)

Please some one help me asap.

thanks

nivas

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Mar 16, 2007 at 03:28 PM

    Nivas,

    HTTP response code 4XX wouldbe generally due to an authentication failure.

    Check the user credentials if you are using FTP to poll the file.

    -reg

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 16, 2007 at 03:42 PM

    HI,

    see the below not only RFC destination entry, there should one RFC destination .

    • 404 is an HTTP response code that indicates that the resource in question couldn't be found. Usually this is due to an incorrect URL, so it is better to cross check all URLs. Check pipeline URL in the SLD in the business system of the Integration Server For this go to SLD->Business System-><yourIntegrtaion Server>->Pipeline URL: It should be like this http://<host>:<port>/sap/xi/engine?type=entry Where host is the host name of the Integration Server and port is the HTTP(8xxx) port. To verify this in Integration Server you can do like this. Go to SXMB_ADM->Integration Engine Configuration->Choose Edit from Menu -> Change Global Configuration Data to switch to change mode. Then select System Landscape - Load Configuration. (This is not required always)

    • Check that the port really is the ICM HTTP Port and not the J2EE port i.e SMICM then menu GOTO --> SERVICES and check the port number for HTTP. It should be HTTP port

    • If the error is Page cannot be displayed, cannot find server in https configurations Check and correct the SSL configuration for the ABAP and the J2EE side of the system

    • If the error is because of integration server when using Proxy communications then check these. i.e SXMB_ADM->Integration Engine Configuration->Corresponding Integration Server enrty should be dest://<Http Integration server-Destination> Where < Http Integration server -Destination > is the RFC destination (SM59) of type HTTP connection (type H) to the Integration Server. In this case, host name, port, and path prefix are saved in the RFC destination.

    Regards

    Chilla

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      hi,

      well i did changed exactly in the steps.

      i changed the global configuration data and selected the SLD now its show the url.

      created teh RFC destination with H option test connection working file. the problem stays.

      thanks

      nivas

  • avatar image
    Former Member
    Mar 16, 2007 at 03:52 PM

    Hi Nivas,

    <i>In Corresponding Integration server there is no entry in the system. ( if this is the problem how to change it)</i> - in XI in SM59 transaction, go to HTTP conn, create a new conn of type HTTP conn to your XI intergration server.....give target host as the IP of your XI server.....give logon security as SAP standard.....then save this conn.....test if this conn is working......then your File scenario will be executed.

    Thanks,

    Rajeev Gupta

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 16, 2007 at 09:25 PM

    Hi,

    1) Did you maintain Client, userid, password, and lang information in SICF transaction -> sap/xi/engine ? Double click on service and check whether you have entered correct information.

    2)Access the trace file and search for traces with severity ERROR, WARNING or stack traces.

    If we do not find an error in the log file or the error message does not explain the problem sufficiently, access the default Trace. The default trace file contains detailed messages for developers. Extract the relevant trace information e.g. using the time stamp or the message ID.

    If this does not explain the problem in more detail, increase the trace level and reproduce the problem. Then restart message processing using the message display tool. Mark the message and select repeat.

    3)Check the Note-803145

    4) 404 is an HTTP response code that indicates that the resource in question could not be found. Usually this is due to an incorrect URL check all URLs.

    5) http port - should be the icm http port, not the J2EE http port. confirm it by in tcode- SMICM and then Goto->Services. Use the http port .

    Regards

    Agasthuri Doss

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 17, 2007 at 01:51 AM

    nivas,

    in correspoding Intergation server goto SXMB_ADM->intergationserverConfiguration->their you select it role of the system.

    Add comment
    10|10000 characters needed characters exceeded