Skip to Content
0

FBL5N : DUMP : GETWA_NOT_ASSIGNED

Jun 01, 2017 at 10:08 AM

210

avatar image

Dear All,

I am getting the error : Field symbol has not yet been assigned.

I am getting this error only in one layout . So I am wondering why only one layout is giving this error , other layouts are fine I am not getting dump in other layouts .

Unable to find the error in which field catalogue or layout this error is coming .

The current ABAP program "SAPLKKBL" had to be terminated because it has come across a statement that unfortunately cannot be executed.

You attempted to access an unassigned field symbol (data segment "-1"). This error may occur if - You address a typed field symbol before it has been set with ASSIGN - You address a field symbol that pointed to the line of an internal table that was deleted - You address a field symbol that was previously reset using UNASSIGN or that pointed to a local field that no longer exists - You address a global function interface, although the respective function module is not active - that is, is not in the list of active calls. The list of active calls can be taken from this short dump.

Information on where terminated .

Termination occurred in the ABAP program "SAPLKKBL" - in "HEADER_FIELD_OUT". The main program was "RFITEMAR ". In the source code you have the termination point in line 1246 of the (Include) program "LKKBLF01".

Please guide how to fix this error .

Regards

Deep

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Raymond Giuseppi
Jun 01, 2017 at 11:27 AM
1

Use one layout that doesn't dump and execute an ALV consistency check. Consider also running, once only, a BALVBUFDEL if not already done.

Show 10 Share
10 |10000 characters needed characters left characters exceeded

Dear Raymond ,

Sir Thanks for your valuable reply.

I did the same thing I have used that layout only which is not getting dump .It works fine .

Unable to do the ALV consistency check .

Also , I have executed the program : BALVBUFDEL and I get the message : -

%F buffer of EUINFO/LTEX has been reset

I also want to add some more information to this issue that :-

On another layout that doesn't dump I executed the report and then I go to settings--> switchlist .

By this way the output of the alv list display changed to alv grid display .

Then I again run the same layout which is showing dump .And now there is no dump with that layout and I am able to see the output in alv grid format .

But with list display I am getting the same error .

Please suggest as I am still getting the same error with list display .

"Field symbol has not yet been assigned."

0

What do you mean by "Unable to do the ALV consistency check" no shift key on keyboard, no right button on mouse, no free finger, list not displayed as grid?

In the last case switch display mode (Menu Settings, switch list) , for the other cases I'm afraid I can't do much.

0

Dear Sir ,

I am doing the same thing for ALV consistency check .

I have followed this link :http://saptechnical.com/Tutorials/ALV/Consistency/Index.htm

But unable to do the ALV consistency check .

I press SHIFT + (Double Right Click) on any empty section of the ALV output screen of the Report but it does not go consistency check of ALV grid control .

Moreover , If I execute the FBL5N report with /abc layout (layout which goes for dump with alv list display )

Alv grid display is fine with no errors with that layout /abc but as soon as I changed the display from GRID TO LIST display .

As you suggested : Menu Settings, switch list .Then it goes for dump in ALV list display .

It is showing in the status bar as 7 items displayed but there is no display in the output and it shows a dump .

"GETWA_NOT_ASSIGNED"

"Field symbol has not yet been assigned."fbl5n-dump1.jpg

Regards

Deep
fbl5n-dump1.jpg (95.3 kB)
0

Deep,

For ALV Grid Display - /abc layout

For ALV List Display - Do you have the same layout ?

Check the list of fields in both the layouts.

K.Kiran.

0

Dear Kiran K ,

Yes I have the same layout /abc for both GRID and LIST display .

It goes for dump in ALV LIST DISPLAY with same layout /abc.

With ALV GRID display with same layout it is fine with no dumps .

Regards

Deep

0

To execute consistency check you must click in the ALV container area in a free zone (Once switched to grid, scroll the table to the last column and click just right of this last column, some warning for class grid can dump the good old FM hidden behind list and vice-versa)

During you analyzis of the dump, which exact field did trigger the dump (usually some box, style or color field) or did it trigger in some List event like a top_of_page or so?

area.png (1.5 kB)
0

Dear Raymond ,

Thanks for your valuable reply .I am able to do the consistency check for ALV.

I am getting these 4 messages on doing the consistency check of ALV GRID control : -

1) Field catalog contains more than 99 columns to be output

2) Field PRODPER has different data type (ACCP) and internal type (N)

3)Field PRODPER has a wrong value ACCP in FCAT-DATATYPE

4) You tried to output 138 columns, but max.

alv-consistency-check.jpg

Please suggest what to do next .

Regards

Deep

0

Those "errors" shouldn't trigger dump, so look at the dump to identify the field which were not assigned (or export dump in a character format (txt, html) and attach it to the discussion if you are not successful)

0

Dear Sir ,

I have done the following to save the file in text format .

I run the tcode : goto st22 and path

System->List->Save->Local File-> unconverted .

So I am able to download the file in txt format . FBL5N.txt file . But this file I am unable to attach to our discussion .I am getting the message : -

"This attachment is not permitted because the file type is invamessage.jpgmessage2.jpglid."

So please tell how should I attach the dump log to our discussion .

Regards

Deep

message.jpg (18.0 kB)
message2.jpg (25.7 kB)
0

Test: test.txt

test.txt (9 B)
0
avatar image
Former Member Jun 02, 2017 at 10:02 AM
1

Hi Deep,

You need to Sit with the ABAPer and get it Debugged . There is a Possibility that some Customization Example Addition some More Coulumns would be there in the Form of the BADi and which might not be active or something incorrect with the BADi or some other Customization. Otherwise such a thing would never happen. There Could be Some Enhancement Spots which could be Impemented by the ABAPers as I said for adding a Column in FBL5N where something Could have gone wrong.

Thanks..

Regards,

Deepak.

Share
10 |10000 characters needed characters left characters exceeded
G Lakshmipathi
Jun 01, 2017 at 01:29 PM
0

If I remember correct, Field Catalogue are case sensitive and you need to ensure this

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Dear G lakshmipathi ,

How I can ensure in standard that the fields are all in capitals , In catalogue table they are appearing in capitals only .

I believe in standard they will be correct .But I am wondering how I am getting this error GETWA_NOT_ASSIGNED"Field symbol has not yet been assigned."

The layout /abc going for dump .

I will tell you when I am getting this error :-

1) When I am taking one of the layout /abc . This layout goes for dump in list display but for the Alv grid display it is fine with no dumps .

Only layout /abc goes for dump in ALV LIST display .

2) Secondly, If I take another layout other than/abclet say example/defthen execute the FBL5N report with/def layoutthen report output is fine and there is no dump and now I changed the GRID DISPLAY to LIST DISPLAY by going to settings--> switch list .It is fine in both the displays grid and list .

But withlayout /abcwhen I execute the FBL5N report with /abc layoutthen I am not getting the dump because the display is now ALV GRID Display .I am getting the output fine . If here I changed the grid display to again the list display by going to settings--> switch list .Then again I am getting the same dump : same error GETWA_NOT_ASSIGNED"Field symbol has not yet been assigned."

So I am unable to identify and correct what problem exactly is there in the layout and catalogue why I am getting the dump in ALV LIST display with /abc layout .

Why list display is going for dump .Please suggest some ideas .

Regards

Deepfbl5n-dump1.jpg

fbl5n-dump1.jpg (95.3 kB)
0