Skip to Content
0

ZKQ is not displaying correct leave balance month wise

Jun 01, 2017 at 08:53 AM

64

avatar image

Hi All,

We have 3 requirements:

[1] We are trying to display Leave opening balance ANZHL, Leave availed KVERB and Leave Closing balance REST from table ZKQ on the payslips using PE51. Identifier used S*03.

But output is not showing values monthwise though we are running payroll monthwise. How can we make sure that on payslips, leave data doesn't comes cumulative but monthly?

[2] We are trying to write custom code to get leave balance from previous year, then subtract the number of leaves taken, leave encashment and leave adjustments in current year. We are getting leave balance for current year after above calculations, but this is not equal to opening balance for next year. We have run PT60 for the test pernr in this custom code.

We are using CALL FUNCTION 'HR_FORMS_TIM_GET_B2_RESULTS' and getting results from ABWKONTI and getting above error.

[3] Whenever PT60 is run for any employee, it executes from 01/2015 instead of period selected on selection screen. It executes for all periods and hence Base Entitlement and other fields are getting effected.

Request you all to help me out as I am a technical resource (ABAP) and we don't have any Functional to help us out. You can answer all 3 of them or separately.

Do let me know if any more information is required from my side.

Regards,
Abhinav

+91-7350006301

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers