Skip to Content
0

Web IDE Master Detail app not working

Jun 01, 2017 at 06:54 AM

278

avatar image

Hello experts,

I have created a project in Web IDE using the SAP Fiori Master-Detail Application template and used the ES4 demo gateway system to consume the GWDEMO OData service. On running the app I see the below error in the developer console:

Uncaught (in promise) TypeError: Cannot read property 'createRenderer' of undefined

Is this some bug in Web IDE as earlier we were able to successfully run the projects from Web IDE. Currently this behavior is being seen irrespective of which system I use for the data consumption (Northwind, on-premise gateway etc.).

Also the app is not able to resolve the relative path to the sap-ui-core.js mentioned in the bootstrap: src="../resources/sap-ui-core.js", I can see errors $ is not defined in the console.

Regards,

Saurabh

capture.png (66.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Michal Keidar
Jun 01, 2017 at 07:22 AM
0

Hi,

How do you run the app? As a Web Application or as a Fiori component in a sandbox?

Regards,
Michal.

Show 6 Share
10 |10000 characters needed characters left characters exceeded

Hi Michal,

I am running the app as a Fiori component in Sandbox. Also I forgot to mention this in my original post - this behavior is happening only when I create the Master-Detail project with the default SAPUI5 version (1.46 SAPUI5 Innovation). If I select 1.44 and create the project it runs perfectly.

Regards,

Saurabh

0

And what is the UI5 version that is installed in your ABAP system?

0

I have not deployed the app from Web IDE on my ABAP system. I am running it from Web IDE itself.

0

I see.

@Elina Visoki - can you please advise?

Thanks,
Michal.

0
Former Member

Hi Saurabh,

In order to better investigate the issue, please provide the landscape you are working on (WebIDE url) and the project you are using (is it just Master-Detail project as created from template or did you add your code to it?)

Also, I understand the problem is only when you choose 1.46 ui5 version, right?

Regards,

Raya.

0

Hello Raya,

I am using the Master-Detail template to create the project - I am not adding any of my own coding in it. I am just trying to run the generated project as-is.

The Web IDE url I am using is https://webide-p704622trial.dispatcher.hanatrial.ondemand.com/

Also I have seen the reported issue only when I use the SAPUI5 version 1.46, for older versions the output is shown fine.

Regards,

Saurabh

0
Michal Keidar
Jun 08, 2017 at 10:09 AM
0

Hi,

This seems to be a bug, and we are working on providing a fix.

As a workaround you can remove the “hc_serviceversion.sapui5=snapshot” parameter from the URL.

Regards,
Michal.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Michal, the workaround you suggested works fine.

0