Skip to Content
0
Former Member
Mar 15, 2007 at 08:49 AM

DBATL reorganization with brspace failed ORA-12008, ORA-01410, ORA-06512

158 Views

Dear all,

We are using SAP R/3 4.6C, with 4.6D_EXT kernel 2271, Oracle 9.2.0.5

and HP-UX 11.23.

We plan to migrate Oracle into version 10g.

As a strongly recommendation from the SAP guide for Oracle migration is

the Oracle migration of the tablespaces from dictionary into locally managed.

I finished the migration on the test environmetn, using oracle nativ commands for export, brspace for drop, sapdba for recreate and oracle import. But, some problems with SAP data classes appeared in the tables TAORA, IAORA, TSORA and others.

Now, I started the procedure with brtools like in the Note <b>646681</b> -

Reorganizing tables with BRSPACE especially as in the <b>Remark 14</b> from

the note.

First I created Oracle scripts for export and import for every

tablespace (except System, PSAPROLL and PSAPTEMP) then I shutdown the

SAP instance,

Then created PSAPAUX?? tablespaces for every tablespace like:

brspace -f tscreate -t PSAPAUXDD -s 100 -a yes -m 1024 -i 10 -d both -l

PSAPDDICD

Then I moved the tables like in the step 3 from the Remark 14:

brspace -f tbreorg -t TAORA,DDART,DARTT,SVERS,MLICHECK,DDNTT -n

PSAPAUXDD

brspace -f tbreorg -t DD09L,DD02L,IAORA,TSORA,IGORA,TGORA -n PSAPAUXES

brspace -f tbreorg -t DBATL,DBAML -n PSAPAUXST

brspace -f tbreorg -t SDBAD -n PSAPAUXPR

<u>after this command the following error occurred</u>:

BR0301W SQL error -600 at location BrsDblogOpen-6

<b>ORA-00600</b>: internal error code, arguments: [kcbnew_3], [1], [], [], [],

[], [], []

brspace -f tbreorg -t SDBAH -n PSAPAUXBT

Started the export for all.

Drop tablespace PSAPSTABD and PSAPSTABI (warning about the same ORA-

00600 occurred)

Recreate the tablespaces and import script finished <b>OK</b>.

When I tried to reorganized the tables DBATL,DBAML with the following

command

brspace -f tbreorg -s PSAPAUXST -t "DBATL,DBAML" -n PSAPSTABD -i

PSAPSTABI

DBAML was successfully moved into PSAPSTABD but DBATL not:

BR1124I Starting reorganization of table SAPR3.DBATL ...

BR0280I BRSPACE time stamp: 2007-03-08 12.25.32

BR0301E SQL error -12008 at location tab_onl_reorg-20

ORA-12008: error in materialized view refresh path

ORA-01410: invalid ROWID

ORA-06512: at "SYS.DBMS_REDEFINITION", line 8

ORA-06512: at "SYS.DBMS_REDEFINITION", line 146

ORA-06512: at line 1

BR0280I BRSPACE time stamp: 2007-03-08 12.25.32

BR1106E Reorganization of table SAPR3.DBATL failed

I started the <b>sapdba</b> tool and tried to reorganize the table DBATL from PSAPAUXST into the right tbs PSAPSTABD, sapdba also said ORA-01410: invalid ROWID but as warning.

I ignore the warning and the reorganization finished successfully.

After this I continue with the procedure for migration of the tablespaces with export, move tables in AUX tablespace if needed, drop, recreate,

import, and move back tables if they were moved.

Everything now is done successfully!!!

The alert log doesn't have any ORA errors now.

My opinion is because of tbreorg of the DBATL table like in the Note 646681 - Reorganizing tables with BRSPACE especially as in the Remark 14 from the note, the ORA errors occurred. When I moved back the table into the corresponding tablespace PSAPSTABD the errors disappear.

Did anyone performed the Oracle dmts into lmts migration and used reorg of table DBATL? Did anyone got ORA-errors after this?

Thank you in advance.

Many regards,

Ruzica Kalkasliev