Skip to Content

SQL2059W A device full warning was encountered on device - when trying to fix Backup Pending

Hi all

Trying to do a DB2 import as part of a system copy and the transaction logs filled up. Import was cancelled, transaction log backup ran, and number of logs were increased to approx 90% of the available disk (previously 70%).

Restarted DB and kicked off DB but now that errors due to the tablespace state - running "db2 list tablespaces show detail" shows I have 4 tablespaces in Backup Pending state.

So I tried "db2 backup database <SID> tablespace <SID>#BTABI online" but I get the error:

SQL2059W A device full warning was encountered on device "/db2/db2<sid>". Do you want to continue(c), terminate this device only(d), abort the utility(t) ? (c/d/t) t

No option works but to terminate.

The thing is, the device isn't full. There's no activities on the DB, running "db2 list applications" gives:

SQL1611W No data was returned by Database System Monitor.

Running "db2 "select log_utilization_percent,dbpartitionnum from sysibmadm.log_utilization order by 2"" to show the log utilization returns 0.

There's no logs in use. The filesystem has space free. I even tried reducing the number of logs again to make sure but get the same issue.

I tried 'db2 "alter tablespace ECD#BTABI switch online"' instead and although this returns a 'success' statement it doesn't actually do anything - my tablespaces are still in Backup pending?

Any ideas please

Thanks Ross

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jun 05, 2017 at 12:53 PM

    I was mistaken, the default location where it was trying to backup that tablespace to (not trans logs) didn't have sufficient space. I did a full backup to a different area and this cleared the issue (seems I could have also done a backup to dev/null).

    Add comment
    10|10000 characters needed characters exceeded