Skip to Content
0

Agentry bug deleting objects in front end

May 31, 2017 at 02:58 PM

45

avatar image
Former Member

Hi Guys,

Im facing an issue with Agentry. When we create a new Notification from mobile device all is working perfectly and the bussines process is ok but when we synchronize and the local object is deleted after transmit some data is cached into device as we can see in the next screen.

As we can see the notification inbox is empty but the value is persisted at the detail screen. In the next screen i'll show the agentry object tree to see that the notification collection is empty.

And the rule to update the value needs data from the notification object to return any value

Any idea?

Thanks!

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Bill Froelich
Jun 05, 2017 at 01:41 PM
0

I have seen this in the past. The detail pane is just not refreshing when the underlying list becomes empty. You don't mention what version of the WPF client you are using but I can tell from the screenshot that it is a pre-SP12 client. Given that the current version is SP14 + patches I would strongly recommend you first try with the latest available WPF client. This will also have the benefit of improved transmit times (especially for the initial transmit).

If that doesn't solve the issue you can work around it by using a second detail field that display a static message (no notifications) or something similar when the list is empty using hidden rules. The products did this as well at one point so you may be able to find an example in the application still.

--Bill

Share
10 |10000 characters needed characters left characters exceeded