Skip to Content
0

Bex Query Corrupted which is on HANA Analytical Views

May 31, 2017 at 11:17 AM

60

avatar image

Hi ,

I have created Attribute and Analytical views in HANA modeling.On top of this Analytical Views i created Bex query's .Environment is BW 7.4 SP 12 on Hanastudio 2.3.23 where i can see all the HANA packages as Infoareas in Bex query designer and I am able to create Bex queries on top of Analyitcal Views.

But when I have adjusted the analytical view by adding another attributeview and then reopened the bex query to add the additional fields from the model . When i have done this i am facing error like the bex query is corrupted with an error :" Infoprovider doesn't exist with some random ID "

And Later on i am not able to create new query on that Analytical view.The view is appearing and working fine at HANA but not appearing at Bex query designer.

All the fields in the analytical view will appear as an infoobject at query level with some Random technical name and the technical names of these infoobjects are being changed whenever im trying to add/activate analytical view with some additional fields(I am not removing the fields from the view i am adding the new fields).Due to this the query is getting corrupted and the analytical view will no longer visible at Bex query level.With the impact of this i have to recreate the model right from the scratch.

Can someone please let me know why this happens.I have gone thru many blogs and i found many blogs that are related to consuming BW data into HANA Views which didn't suit in my scenario.

bex-query.jpg

Thanks in advance,

Regards,

Karthik K

hana-view.jpg (19.1 kB)
bex-query.jpg (105.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers