Skip to Content
0

Universe Objects are not visible in WebI (missing dimensions and measures)

May 31, 2017 at 10:11 AM

857

avatar image

Hi Experts,

I have experienced a very strange issue related to the missing objects in the universe when using WebI. Luckily I have created a copy of the universe so this have not caused a lot of troubles. The copy of the universe has some changes comparing to the original universe. The copy universe I will name "DEV Universe" in this thread. The universe is .unv format (UDT).

The folder "old" containing multiple subfolders, measures and dimensions has been re-created and named folder "A". We needed to have two folders to see the differences between the new and old dimensions/measures. After the successfull UAT I have deleted the old folder "old".

Important Note:

I have created a copy of WebI report and wanted to re-map to use the new universe. Meaning that during the re-map process I needed explicitly point to the dimension/measure because the object IDs are different between the universes (the naming is the same or very similar).

Symptom:

  1. Many objects in WebI are not visible even though they are visible in the universe

Looks like that the objects would be hidden or the universe row level security/restriction would be applied. I have checked it many times - it is not.

Universe:

WebI:

Possible Cause:

I have tried to re-map one complex WebI report from PROD to DEV Universe for development test purposes. The report is using 10 queries where some of them are combined queries using intersection. All the queries are using the same universe and all of the queries are using dimensions/measures that have been changed in DEV universe.

I have been able to re-map the first report's combined query (intersection) with the WebI Java Applet. The mentioned first query is using many dimensions and one Measure "#1A" Then I have tried to re-map the second WebI Report's query and I have noticed that I am not able to explicitly select the object in the DEV universe that I would like to use. Later I found out that all the objects in the DEV universe that are below the measure "#1A" are gone! Note that this measure "#1A" has been used in re-map process before.

I have tried to create a new report and add all the folders, sub_folders, dimensions and measures that were below the measure "#1A" were not visbile. On the other hand, everything looks fine on the universe. I can see the missing objects, tables, joins, their preferences, etc.

What I have done so far:

  • import/export the same unvierse (didn't help)
  • change the title and export the universe (didn't help)
  • export the universe to another location-folder (didn't help)

It seems that the universe object links got corrupted during the re-mapping process and now the missing objects are not visible in WebI.

I have tried to create a copy of the missing folders and they are visible in WebI once I place them above the corrupted measure "#1A". It seems that everything below the corrupted measure "#1A" is not visible. Have tried to create new measures and they are not visible in WebI as well. I have tried to rename the corrupted measure or folder and I could not see that they will be renamed in WebI after exporting the universe.

Do you have any ideas what could have possibly went wrong? Any ideas how to solve this issue?

I am using SAP BO 4.2 SP2.

1a.png (225.7 kB)
2b.png (26.4 kB)
3b.png (96.5 kB)
10 |10000 characters needed characters left characters exceeded

Do you see the objects if you create a new report? If so, the problem would appear to be with the universe-switch function and not the universe itself.

What happens if you rename "Measure #1A", or move it to the very bottom of the universe structure?

0
No, I do not see the objects in the new report. If I rename the universe the title stays the same. If I rename the other object to get the same name then I get the error only in WebI.

I found out the cause and solution that is related with Translation of the universe.

0
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Vytautas Thienel Jun 01, 2017 at 11:01 AM
0

I have found the cause of the problem and a solution how to solve it.

The translation for the corrupted measure #1A was causing the issue in WebI. I have checked the measure #1A using Translation Management Tool and noticed that the format of this measure was the title of the measure. I have changed it to "Numeric Format" and everything works fine. In WebI I can see and use the missing objects.

The measure #1A is renamed to [!] No... Above is the example how the measure should look like.

I do not know if just importing-exproting the translation wouthout changing the format of this measure would have solved this issue as well. Since I do not have the corrupted I cannot test it anymore.


7a.png (32.6 kB)
Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member May 31, 2017 at 04:25 PM
1

Have you force the Webi universe cache to be deleted located in "Output cache directory"?

Regards,

Jin-Chong

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Jin-Chong, thanks for a good idea. I really thought that this might be related to universe cache.

In directory BO_location/enterprise_xi40/Data/server_6400/server.WebIntelligenceProcessingServer/sessions I found all the cached sessions and deleted all of them that have been using the DEV universe (unv with problem). Unfortunatelly it did not help. I still get the same issue once trying to create a new report in WebI. In addition I have tried to do that using another PC or BO user and it did not help either. Then I have deleted all the cache sessions that was until today, just to be sure that there is nothing causing this issue. But I still not able to see the objects that are below the corrupted measure. There are still few seassions from today that are using another universe. I do not want to delete them because the users might be using WebI.

Is there any other location where the universe cache could be stored?

0
AMIT KUMAR
May 31, 2017 at 10:35 AM
0

are your objects in universe like below mode in universe?


untitled.png (1.1 kB)
Share
10 |10000 characters needed characters left characters exceeded
Vytautas Thienel May 31, 2017 at 12:23 PM
0

Thanks for the quick reply.

No. They are not hiden and there is no row level security applied.

In addition, if I will copy the measure that is missing and paste it in a folder that is above the "corrupted" measure #1A it will be visible in WebI. See the screenshot below that ilustrates the WebI on objects that have been moved from Folder A to new folder Test NEW. Note that the measures that I have moved are exactly the same that have not been visible in WebI before.

Then I have tried to move the missing objects above the Measure #1A within the same Folder A and they are visible in WebI. So it really has something to do with Measure #1A that has been used during the universe re-mapping process (change source).


4a.png (68.6 kB)
4b.png (107.2 kB)
Show 2 Share
10 |10000 characters needed characters left characters exceeded

are you picking the objects from the exported universe.sometime we have same universe in multiple folders and that will create confusion.

have you tried to open the exported universe after webi logoff and login?

0
I have tried to open the exported universe after logoff/login many times. I have tried to log in with different users including the Administrator and still get the same issue.
0
Vytautas Thienel Jun 01, 2017 at 09:02 AM
0

I have noticed that corrupted is not only the measure #1A but also the folder "Folder A".

  • Once I rename the measure or the folder in WebI they still have the same name.
  • Once I have deleted the corrupted measure #1A everything (objects and subfolders) in the Folder A was visible but the other folders below "Folder A" were not.
  • Once I have deleted the "folder A" and the measure #1A the rest of the universe objects were visible in WebI including the copies of the Folder A and measure #1A.
  • Once I have renamed corrupted "folder A" to "folder A copy 2" and renamed any other folder to "Folder A" I have got an error in WebI

This seems like an easy way to solve the issue. Although I have noticed, that once I have deleted the corrupted object and folder the title of the universe in WebI changed to a very long one. Basically in the title were the list of object tiltes I have deleted.

Then I have noticed that there are translations for this universe.

Will check the Translations and update what I have found.


5b.png (12.8 kB)
6d.png (40.2 kB)
Share
10 |10000 characters needed characters left characters exceeded