Skip to Content
0
Former Member
Mar 14, 2007 at 09:25 AM

CX_RSR_X_MESSAGE when creating update rules

22 Views

Hi,

I'm trying to activate SAP Demo scenario for procurement, infocube 0D_PU_C01. I have activated everything except for update rules. Activation of update rules fails with CX_RSR_X_MESSAGE short dump. When I try to create UR manually I get the same error after filling the first screen.

I'm getting pretty out of any ideas. I debuged the error, the deepest I could get was the RST_TOBJ_DERIVABLE function module, called with parameters:

I_TIMNM_FROM = '0CALDAY'

I_TIMNM_TO = '0CALMONTH'

The FM goes like this:

*... ist überhaupt eine Zeit ?

IF cl_rsr=>check_time( i_timnm_from ) EQ rs_c_false.

e_subrc = 4. RETURN.

ENDIF.

The first line with method cl_rsr=>check_time with parameter '0CALDAY' falls into short dump.

I tried to go deeper, inside the cl_rsr=>check_time method the function module RRSI_VAL_SID_SINGLE_CONVERT is called with parameters:

i_iobjnm = '0IOBJNM'

i_chavl = '0INFOPROV'

- that's where the short dump occurs. The error is quite deep and I dont't see the logic of the code. I just checked for existence of these infoobjects - 0INFOPROV is active, 0IOBJNM doesn't exist (not even business content version).

Anybody help please... Our version is SAP NetWeaver BI 7.0, latest support package SAPKW70012.

Thank you,

Marek