Skip to Content
Former Member
Mar 13, 2007 at 04:36 PM

Error when Generating the Program


Recently there was an SP upgrade and my Planning Book started giving me this error message (SCM version =5.0 and SP = 7)

"Error when generating the program" Message no. /SAPAPO/TSM141

Diagnosis: Generated programs are programs that are generated based on individual data objects, such as planning object structure, planning areas and Infocubes. These programs are then executed in the transaction. An error occured during the generation of such a program

Possible causes:

1. The template has been corrupted

2. The object that the template uses to generate the program contains inconsistencies; for instance an Infocube has not been activated


This error occurs when I try to open the my planning book/creating the selection profile. I've re-activated the Infocube and later deactivate and active my POS and tried to do the same for the Planning Area....but the error still persists. I tried to create a new planning area and tried it again but the error still persists. I've tried to fix any inconsistencies in the planning area time series objects by running the consistency check....however the same error pops up during the consistency check....

Anyone encountered this error message and any possible solutions to this issue.