Skip to Content
0
Former Member
Mar 13, 2007 at 10:05 AM

CRM 5.0 Custom BSP takes whole viewarea

30 Views

Hello all,

I created an entry in my navigation bar where I launch a custom BSP. When I click the entry the BSP opens up fine but the navigation bar, error bar and history navigation bar are gone. The telephony function and the bottom bar (with date and time) are still visible however.

I followed all the steps as described in the cookbook to add custom view (and viewset) and controller and created them through the wizard in the IC workbench.

The custom BSP page is currently empty and only has a button in it.

<%@page language="abap"%><%@ extension name="htmlb" prefix="htmlb"%><%@ extension name="xhtmlb" prefix="xhtmlb"%><%@ extension name="crm_bsp_ic" prefix="crmic"%><%@ extension name="bsp" prefix="bsp"%>

<crmic:tray2 frame="1" height="100%" id="de" title="<%=otr(CRM_BSP_WD_TOOLS/SAMPLETRAYTITLE)%>" width="100%">

<crmic:trayBody2>

<crmic:gridLayout cellSpacing="1" columnSize="8" height="100%" rowSize="6" width="100%">

<crmic:gridLayoutCell colSpan="8" columnIndex="1" horizontalAlignment="LEFT" rowIndex="1">

<crmic:button design="EMPHASIZED" id="SAMPLE_BTN" onClick="SAMPLE_BTN" text="<%=page->otr_trim( 'CRM_BSP_WD_TOOLS/SAMPLEBUTTONTEXT' )%>"/>

</crmic:gridLayoutCell>

</crmic:gridLayout>

</crmic:trayBody2>

</crmic:tray2>

I declared my viewset in the MainViewSet.xml file:

<ViewSet id="IC_BASE/workViewSet">

<ViewArea id="workViewSetArea"

views="<%@include file="../CRM_IC_DT_REP/StdWorkareaOccupation.xml" %>

CRM_IC_AUTO/VehMDViewSet <b>../CONTACT/CRM_IC/CustomFactSheetViewSet</b>"/>

</ViewSet>

I already tried different ways of referencing the viewset /CONTACT/CRM_IC/CustomFactSheetViewSet, CONTACT/CRM_IC/CustomFactSheetViewSet. Of course all other configuration, as described in the cookbook, has been done.

Anyone encoutered the same problem before?

Many thanks in advance,

Regards,

Joost