Skip to Content
0
Former Member
Mar 13, 2007 at 12:36 AM

Integrated Planning: Assigning Command to Buttons IN WAD

7 Views

Hi

I would like some clarification on the following problem I am experiencing.

I have set up my Agg Level,

Filter (this includes a cost center hierarchy node)

Function (distribution by keys)

When I run my function from the command wizard, the distribution is executed for all cost centers in the filtered cost center node. This is usefull as managers can execute distributions for their cost center node.

I have also created a NW2004s planning query for aggregation level. The query incudes a variable for cost center / hierarchy.

I have assigned the planning function a button using the command wizard.

Under selection binding for the command I have assigned the characteristic "0COSTCENTER"

Binding type "data provider selection"

If I select a single cost center (leaf) in the variable, execute the template, and then run the function using the command button in the template, the distribution works as expected.

If I select a node in the hierarchy in the variable, execute the template, and then run the function, a termination occurs.

If I select a node in the hierarchy in the variable, execute the template, filer on one or more cost centers (leafs) and run the function, the distribution works as expected.

Now my question:

I was able to run the distribution from within the command wizard, where the filter included a cost center node.

I was not able to run the distribution from the input ready planning web template when a cost center node was selected.

Is this correct?

It would be really great for a cost center to select a node in the cost center hierarchy, execute the web template and then run planning functions for their branch / division without having to select multiple single values.....