Skip to Content

​What has changed technically from BC6 to BC6.5 in regards to logon in to BC-Connections?

May 30, 2017 at 08:43 AM


avatar image

We have the following Situation:

BC-URL is:

there's a WebGui (ITS) running, but access is allowed only in certain case.
If I open that URL in my Browser, LogOn is denied. (as I’m not one of those cases, and that’s fine).

With BC6, connecting to the System worked fine.

With BC6.5, same BC-URL, it doesn't work anymore -> I run into the restrictions imposed to the WebGui.

(SapGui Logon is fine with 750, as it was with 740).

It seems to me, that BC6 did it's login on a "SapGui-like" path, while BC6.5 seems to take a "WebGui(ITS)-like" path instead?

Do you have any insight or further resources in regard to the changes to the login procedures to BC-Connections between BC6 and BC6.5?



10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Damean-BF Chen Aug 01, 2017 at 04:00 PM

Just to make sure I understand what you're doing ... You basically have a System Connection of type "SAP Business Client" with URL set to; (9999 = Your port number; typically 8000) and then you click on that link. Then what happens? Is there an error prompt, the system just hangs?

Also, are you running on Win 8 or Win 10?

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Damean-BF,

thanks for your reply!

Yes, it's basically like you describe: I have a connection auf type NWBC to the URL.

When I open it in BC6.5 I get a lot of SSL-Warnings, and when I confirm them, I get the Error-Message that the "Logon-Window to the system could not be loaded with the URL" (not exact wording, but my translation from German).

Please note: we did "mess around" in that system a little bit (implementing LogOn-User-Exit ZXUSRU01), and the fact that I get SSL-Warnings implies that not everything is perfect there, either, but my point is:

Same URL, same system works fine in BC6.0.
So there has to be some difference between BC6.0 and BC6.5 and I would just like to know what that is!

(Idea: as I notice I'm not getting any SSL-Errors on BC6: Is Maybe BC6.5 more "strict" with SSL, not accepting something that BC6.0 said was fine?)