Skip to Content
avatar image
Former Member

Search Criteria - Product ID not working for numeric Internal Goods/Servic

Hi All,

I was searching Internal Goods/Services via Product ID. In the search criteria for Product ID we have given 1* as search criteria and it seach all alphanumeris Internal Goods/Services but not able to give search results for numeric Internal Goods/Services.

Do we need to apply any correction note?

Best Regards

Lovkesh

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Mar 09, 2007 at 12:59 PM

    Hi

    Which SRM version are you using ?

    There is a bug in the SRM Search help. We have faced the same issue quite long time back. At that time, we have to make the changes to the standard search help.

    Let me know incase you need any details.

    Hope this will help.

    Please reward suitable points, incase it suits your requirements.

    Regards

    - Atul

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 09, 2007 at 03:18 PM

    hi,

    In OMSL, except 18 digits mentionned, nothing else should be flagged ( no lexico...) and everything should work well with alphanumeric and numeric items (goods and service)

    Also,refer the foll thread:- Product XXX does not exist in plant YYY or it has been flagged for deletion

    Also,in Your SRM system display leading zeros is checked but in backend - no.

    Uncheck this checkbox in COMCPRFORMAT and try to create SC.

    BR,

    Disha.

    Pls reward points for useful answers.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi

      <u>Try the following OSS notes</u>

      <b>Note 707781 - Product search does not find all documents

      Note 871627 - Incorrect formatting of product ID in Shop transaction

      Note 788339 - Performance problems during call of search help for products

      Note 803414 - Shop: Search for an invalid product returns all entries

      Note 1034811 - Search in product ID if altrntive ID does not return results

      Note 1004975 - SRM@ERP: Dump CX_SY_ASSIGN_CAST_UNKNOWN_TYPE in COMMPR01

      Note 483896 Product search - same product ID from several backends

      Note 419581 EBP-SHP: Product search by logical system</b>

      <u><b>Incase nothing works, better to get back to SAP.</b></u>

      Hope this will help.

      Please reward suitable points, incase it suits your requirements.

      Regards

      - Atul