Skip to Content

Incorrect date display in crystal Report

Hi,

When I drag and drop the date field from my service it shows an incorrect date on the report.

As shown in the screen shot image
How to overcome this issue? Even if I enter different parameter it shows the same incorrect date. It doesn't display date in database.

This question was asked previously but solution not provided. Check below link

https://answers.sap.com/questions/34852/index.html

incorrectdate.jpg (83.9 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    May 30, 2017 at 04:42 AM

    Dates are correct in .xml file.

    The arrival date field was in my second sub-report.

    I tried deleting the entire sub-report, resetting connection, verifying database, closing report and deleting the temporary files.

    I created a new report only to display flight details and called that report in my main report as a sub-report.

    I provided the sub-report link to main report and the original date which was there in database was visible in report.

    By doing this the "junk" date value field problem was solved.

    I think, crystal report saves some dummy data in it's cache.

    I don't know the exact solution but this one worked out.

    Well, Thank you Guys for helping me! Your advice is always helpful.

    Add comment
    10|10000 characters needed characters exceeded

  • May 29, 2017 at 06:24 PM

    Report connects to webservice WSDL, so you should be able to open the wsdl in IE browser and get .xml file.

    Can you check if the dates are correct in .xml file

    Add comment
    10|10000 characters needed characters exceeded