Skip to Content

Prerequists for PI 7.0 to PI 7.4 Upgradation project.

Hi Experts,

I'm working in a small organization. Business is running in SAP PI 7.0 from past 7 years.this year SAP support will end for Java stack in 7.0 so they are ready to upgrade to PI 7.4 single stack. We have limited resources in the organization.only one PI Consultant and two basis admins.

Can any of you please tell me the prerequisites we need for upgrade to PI7.4 in Basis admin level and PI Level?

Thanks in advance

Regards

Govind

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • May 28, 2017 at 09:07 PM

    Hi Govind,

    Manoj has touched on two of the key points for migration. We went from 7.11 to 7.4 a couple of years ago and we had to rebuild one ccBPM scenario and migrate all Seeburger scenarios over to the SAP B2B add-on. The only other addition that I would say is that folks have to familiarize themselves with how to use NWDS for the integration flows and how to manage transports for that content. Aside from that there is a lot of overlap with what experts will already know from previous releases from a developer standpoint. There is probably more learning to be done from a BASIS perspective regarding system configuration and maintenance than anything else.

    Regards,

    Ryan Crosby

    Add comment
    10|10000 characters needed characters exceeded

  • May 29, 2017 at 04:20 AM

    Hi Govind ,

    Would better, if you go for PO 7.5 in this stage .

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Anshul,

      I think PO 7.5 is supported for Cloud systems(please tell me if i'm wrong). If we use 7.5 we need to upgrade ECC system and also our backend systems are legacy systems so those systems will support for PO 7.5 that we need to check.

      Could you please tell me what are the needs for PI7.4 for Upgrade in Basis level.

      Thanks in advance.

      Regards

      Govind

  • May 29, 2017 at 09:34 AM

    Dear Govind Narne,

    In this link you have all the necessary information for the migration, I advise strongly to migrate to version 7.5, which does not necessarily have to be in the cloud, so it can be perfectly configured on premise.

    https://help.sap.com/viewer/p/SAP_NETWEAVER_750

    In this specific document it talks about the upgrade of previous versions:

    https://help.sap.com/viewer/disclaimer-for-links?q=http%3A%2F%2Fservice.sap.com%2F~sapidb%2F012002523100015877492015E

    If you need help, send me a message, I did this same migration a short time ago.

    Best regards,

    Add comment
    10|10000 characters needed characters exceeded

  • May 27, 2017 at 11:52 AM

    Govind,

    Few points:

    Check if you have and CcBPM interface those needs to be re-designed with NWBPM for single stack.

    Are you using any third party adapters and any plan to replace with SAP's adapter.

    Br,

    Manoj

    Add comment
    10|10000 characters needed characters exceeded