Skip to Content
0

Fiori Launchpad Theming

May 26, 2017 at 12:21 PM

391

avatar image

Hello ,

I am having following issues with UI5 Theme designer(s4Hana1610)

1. the transaction /ui5/Theme_designer is extremely slow

2. While creating a new theme, I am able to see the new Company logo and background color in preview mode but the background image is not getting updated.

3. When I run the URL in fiori launchpad, I don'T see the change

https://<host>.<domain>:<port>/sap/bc/ui5_ui5/ui2/ushell/shells/abap/Fiorilaunchpad.
html?sap-theme=CorporateTheme@http://<host>.<domain>:50000/
sap/public/bc/themes/~client-120/~cache-2VCj7NrjFnVx-uDZ8vm6HqrJVPsI

Can anyone pls suggest me the solution

Many thanks

smriti

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Tong Ning May 27, 2017 at 08:08 AM
0

What is the version of UI theme designer, have you try to update it according to note 2471561 - UI theme designer for ABAP: Version 1.22.8?

Share
10 |10000 characters needed characters left characters exceeded
Frank Schuler
May 26, 2017 at 02:07 PM
0

Hello Smriti,

Configuring the Fiori Launchpad theme by URL parameter should work, but is a bit clunky.

Have you tried to set it via transaction /UI2/NWBC_CFG_SAP on your Fiori Front-end server? By the way, there are few good suggestions in this excellent blog by Masayuki Sekihara:

How to set a theme parameter to SAP Fiori launchpad

Best regards

Frank

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Frank,

Many thanks for this blog as it's a different approach. I will try it now. But do you have an idea why I am not able to see the selected backgroung image in preview mode? I can see background color(if i select one) & company logo in preview more but not the background image.

Best Regards

smriti

0
Sharath M G Jun 07, 2017 at 03:23 AM
0

Did you save and build the theme? Many times the changes are previewed but not successfully built.

Also, clear the browser cache. Try the application in browser's in-private mode.

Finally, confirm if you have changed the logo but manually looking into the theme. Download the theme using the SE38 report -

/UI5/UI5_REPOSITORY_LOAD.

Regards,

Sharath

Share
10 |10000 characters needed characters left characters exceeded
Smriti Gupta Jun 07, 2017 at 08:20 AM
0

Hello,

I am able to set the company logo on launchpad using /UI2/NWBC_CFG_SAP. I reset the /ui2/user_profile as per this blog.

https://archive.sap.com/discussions/thread/3667955

Background image is still not getting set. Will proof the version again

Share
10 |10000 characters needed characters left characters exceeded
Smriti Gupta Jun 08, 2017 at 07:28 PM
0

Hello ,

Thanks to all of you for your replies. The background image is working too after installing the latest support note.

Best Regds

Smriti

Share
10 |10000 characters needed characters left characters exceeded