Skip to Content
0

UI Theme Designer

May 26, 2017 at 09:00 AM

83

avatar image
Former Member

Hi Team,

We are running applications over 1.44 version so wanted to use updated belize theme, so currently we are using UI theme designer for creating new custom theme for our applications.

However, we have noticed that UI theme designer is having 1.46.7 version so it is supporting theme css with same version. And when I tried using exported theme from designer, applications are not showing layout at all.

I tried to check all the options where I can select sapui5 version and can use 1.44, however was not able to find any options in UI theme designer.

In UI Theme Designer, Can we select sapui5 versions while creating themes as per own requirements. Please could you help me with this issue. Thanks!

Regards,

Aarti Dhamat

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Frank Schuler
May 26, 2017 at 11:01 AM
0

Hello Aarti,

When you run the UI Theme Designer from your Fiori Front-end server, it should be using the same SAPUI5 version as your Fiori Launchpad and Fiori apps:

The latest UI Theme Designer version is 1.22 and as you can see, I am using UI5 Version 1.44.14.

Best regards

Frank


about.png (65.8 kB)
Share
10 |10000 characters needed characters left characters exceeded
Sharath M G Jul 21, 2017 at 03:22 PM
0

You do not have option to choose the UI5 version. Theme designer just build the CSS for you.

Then, you apply the theme to your UI 5 applications. Version of Custom theme should not impact the UI5 application as its a bunch of CSS classes.

Regards,

Sharath

Share
10 |10000 characters needed characters left characters exceeded