Skip to Content
author's profile photo Former Member
Former Member

Missing documents with ODS 0FIAR_O03. What can I do?

Hello Experts:

I need your help. I am using ODS - 0FIAR_O03 and data source 0FI_AR_4. I realized that some documents are not in my ODS. When a I make a extractor test in RSA3 I see that documents. When I check in the PSA in BW I don´t see that documents. All mine loads are in Delta method.

In the other hand, I am using also ODS - 0FIGL_O02 and data source 0FI_GL_4. In this ODS I have the documents that I don´t have in the other ODS (0FIAR_O03).

Can you explain me why this is happening?

Thanks a lot in advanced.

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Mar 05, 2007 at 07:38 PM

    You would need to load (dependency) the GL line items before you can load the customer stuff. Please disregard if you are on ECC

    Add a comment
    10|10000 characters needed characters exceeded

    • Hello victor,

      Have you implemented note 760973 before this ? If so, then:

      In some cases, new and changed documents will not be extracted after you implement 760973 (in case of 0FI_AP_4 and 0FI_AR_4).

      For example, new documents entered after the implementation of note 760973 and the documents which are changed after the

      implementation of note 760973. i.e., Let's say note is

      implemented on 01.01.2007 and if a document is entered on

      02.01.2007 and this will be a new document. And if a document is entered on 01.01.2006 and cleared on 02.01.2007. These new and the changed documents are not extracted in delta load. For this you have to implement the note 770040 which should solve the issue. Once you implement 770040 you will have to re-init the delta to make sure you have all the data that were missing.

      Please reward this if this solves your issue.

      For any clarifications plz get back.

      Regards,

      Latha R.

  • author's profile photo Former Member
    Former Member
    Posted on Mar 05, 2007 at 08:24 PM

    Do you use standard update rules and if so, do you see any start routine. The start routine may eliminate any document based on some logic.

    Also, try to get a pattern of missing records in ODS that you see in RSA3 and we can figure out.

    One more reason is the delta initialization may not be proper.

    Ravi Thothadri

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Ravi:

      I don´t have any kind of routines or start routine in mine update rules or in mine ODS. All are standard InfoObject.

      The missing records I think don´t have any pattern because I already have similar register in mine ODS with previous extractions.

      Do you have another idea?

      I saw one note in SAP (616331) service market place that I think it could help me but I am not sure.

      Thanks for your help. I assigned your points.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.