Skip to Content
author's profile photo Former Member
Former Member

error in SXMB_MONI

Hi all

i m doing cource in ,but i am facing problems in executing scenario..

my issue is..

I am doing an idoc to file scenario..

taking R/3 as sender system, i had all ALE configuration,sld configuration,

XI configuration(port creation,loading metadata,RFc destination)

when i generate an idoc, it is sucessfully sent from R/3 (we05),

but in <b>XI sxmb_moni the message status is green, with Queue status stopped (RED colour</b>)

when in delete the queue, and restart the message , successfullly target file is generated...

with error in <u>call adapter </u>

<b> Unable to convert the sender service Zidoctofile_reciever to an ALE logical system</b>

can somebody giude me why is it

regards,

Ajay.P

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Mar 05, 2007 at 04:35 AM

    ajay,

    assign a logical system to our receiver filedapter . GOTO ID-click on our File Buinsess system and Menu ->Services->Adapter Specific Identifiers->give correct Logical system name and click to add logical system from SLD .

    you shouldhave logical system created in R/3 for this.

    Regards

    Sreeram.g.Reddy

    Message was edited by:

    Sreeram Reddy

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Mar 05, 2007 at 04:41 AM

    Hi Ajay,

    First of all check your Business system is pointing to the R/3 system correctly ? For this open Business system in the directory and go to Menu ->Services->Adapter Specific Identifiers->give correct Logical system name and client details.

    I just remembered that you have to maintain your adapter specific parameters for your business process. The side effect however is that you have to define the business process name as logical system in your receiving SAP system and that you have to maintain partner profile settings.

    The answer to your question is there in this Blog:

    /people/michal.krawczyk2/blog/2005/03/29/xi-error--unable-to-convert-the-sender-service-to-an-ale-logical-system

    If the above solution doesn't work.....

    You can also try this, don't enter the "adapter specific settings" on the Integration Process. Instead enter a "Header Mapping" Sender Service in the Receiver Agreement. this should be the real sending system.

    When you enter "adapter specific settings" in a BPM, the receiving SAP systems ALE layer thinks the sending system is your BPM - using the method discussed here we are overriding that so that ALE sees that its communicating with the real sending system.

    I hope it helps....

    Regards,

    Abhy Thomas

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.