Skip to Content
0

SSF Kernel Error: Invalid Parameter error while Importing certificate using STRUST

May 24, 2017 at 05:48 AM

272

avatar image
Former Member

error-strust.jpgHello all,

I am trying to setup an HTTPS communication with SAP.
I used the STRUST transaction code in SAP GUI. Then I am trying to Import a certificate as per document in the below link:

http://www.cohesion.biz/kb/KB10000%20HOW%20TO%20Load%20Intermediate%20Certificates%20with%20STRUST.pdf

While trying to import the certificate I am getting below error:
"SSF kernel error: invalid parameter"

I have tried this The error is same for both Binary and Base64 file formats. I have attached the screenshot as well for reference.

I have few questions here:

1. Is the file given in the 'File Path' of correct format ? This file is generated using the 'Keytool' utility. I have also tried this with the Self Signed Certificate created on Windows 7.

2. The document says 'Most certificates will be delivered in Base64 format by the CA.' How can I identify the CA authority?

error-strust.jpg (88.8 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Bartosz Jarkowski May 24, 2017 at 09:09 AM
0

Hi,

you're trying to import the whole JAVA Keystore which is not supported. Please use software like KeyStore Explorer to extract certificates to separate files (as X.509 certificates) and then import it.

Best regards

Bartosz

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member May 24, 2017 at 12:56 PM
0

Hi Bartosz,

Thanks for your quick response.

I have tried using different files viz.

1..jks file, which is created using the keytool tool.

2..cer file, which is generated from websphere.

3..pfx file, which is a self-signed certificate generated on windows from IIS.

Still I am getting same error for all i.e. "SSF kernel error: invalid parameter"

Thanks,

Abhishek

Share
10 |10000 characters needed characters left characters exceeded
Reza Ejersbo Nov 01, 2017 at 10:12 PM
0

Hello,

Did you solved you problem. I have the error in strust.

Please komme with some advice.

Thanks

Share
10 |10000 characters needed characters left characters exceeded