Skip to Content
0

Connect to Hana Database problem

May 23, 2017 at 01:09 PM

242

avatar image
Former Member

Hi

Every time when I try to connect to Hana Database via Visual Studio 2015 i have a problem and information :general error : database 'XXX' does not exist

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Frank Schuler
May 23, 2017 at 01:19 PM
0

Hello Bogumil,

Could it be that you are trying to connect to a multi-tenant system? Then the ports are different:

TCP/IP Ports of All SAP Products

Best regards

Frank

Show 5 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Frank

thank you for your respond, but probably not.

I added port

30015

(see screen above)...

I haven't any problem to connect to this database via Hana studio

i do it for the first time

but when i connect via ODBC i have a problem

(see screen below)

0

Hello Bogumil,

SAP HANA Studio is a different story. Please try port 30013.

Best regard

Frank

0
Former Member

Hi Frank

Hana Studio is set to port 30015 in standard.

What do you mean about port 30013.

have i to change this port to 30013 ?

what am i sopouse to do ?

B

0

Hello Bogumil,

No, leave port 30015 to connect with SAP HANA Studio.

What I mean is that the SQL port is different. You can check this in SAP HANA Studio:

Best regards

Frank

sql-port.png (70.9 kB)
0
Former Member

I haven't any problem to connect to HANA Database via Hana Studio

i have a problem via Visual Studio C# 2015

When i Connect to Hana Database via Hana Studio , a port is : 30015

You told me , when i want to connect through Visual Studio, then port must be different ?

How may a check the port in Hana Studio to connect to Hana Database via Microsoft Visual Studio c# 2015 ?

my configuration is:

in SQL Port i have 30015 and when is use it i can't connect.

Bogumił

check-hana.png (217.4 kB)
my-conf.png (27.0 kB)
0