Skip to Content
author's profile photo Former Member
Former Member

Workload Collector Retention Time

Does anybody know, how i can change the retention time parameter of the statistic data stored in stat.dat for sap-release 7.0 (2004s)?

In release 6.2 there was -> Collector & Perf. Database -> Workload Collector -> Control

and stat/max_files could be changed in transaction RZ10,

like

http://help.sap.com/saphelp_nw04/helpdata/en/ff/0ae73ac6e7ec28e10000000a114084/content.htm

In release 7.0 i can change the stat/max_files, too, but i don't found any possibility to change the retention time.

Transaction ST03G shows the time but i can't changing anything.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Feb 26, 2007 at 09:49 PM

    Hello Marek,

    increasing stat/max_files is sufficient, in 7x there are no additional settings neccessary anymore.

    Please note also the maximum value of 99 for this parameter.

    Regards, Michael

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Feb 26, 2007 at 03:29 PM

    Hi Marek,

    you can change the retention periods in release 7.0 almost the same way as in 6.20.

    Go to transaction ST03. Make sure that you use the Expert user mode. Go to:

    -> Collector and Performance DB -> Performance Database -> Monitoring Database -> Reorganization.

    You will find there all the retention periods and you will be able to change them as you wish.

    For further detail, check the online documentation of nw04s:

    http://help.sap.com/saphelp_nw2004s/helpdata/en/2d/b8be3befaefc75e10000000a114084/frameset.htm

    Regards,

    Constantina

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Yes, thats all moni settings and have no effect for transaction STAD. I have found the correct parameter in table sapwlcolpa, with parametername NORMALSTAT_FILES_KEEP_HOURS and a default value of 48h. But there is no way to change this value in ST03N like in previous releases.

  • author's profile photo Former Member
    Former Member
    Posted on Feb 26, 2007 at 06:16 PM

    To what value is the stat/max_file and stat/as_max_files set? You may have to increase these.

    RSB

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.