Skip to Content
0

SAP Data Services 4.2 Https Issues

May 23, 2017 at 02:13 AM

165

avatar image
Former Member

Hello All,

We are using SOAP Web services with Http which is working perfectly and if we use HTTPS we are unable to load data. We have tried all the options which are mentioned in the Integrator Guide and forums Can anyone help me on this...We don`t have any issues if we use Http but using https is nothing is working for us now, Unable to find any solution for this .

We are using SAP Data Services 4.2 SP8

I can see empty log for axis2.xml in log folder.

C:\ProgramData\SAP BusinessObjects\Data Services\log

Below is error and axis file..

24926116RUN-2480055/22/2017 9:08:40 PMThere is no response for the web service <CreateRebillCustomer>. Ensure that the network, web server, and service are running 24926116RUN-2480055/22/2017 9:08:40 PMproperly. Also ensure that the service client call time out is set properly.

<axisconfig name="Axis2/C">
    <!-- ================================================= -->
    <!-- Parameters -->
    <!-- ================================================= -->
    <!-- Uncomment following to enable MTOM support globally -->
    <!--parameter name="enableMTOM" locked="false">true</parameter-->


    <!-- Set the suitable size for optimum memory usage when sending large attachments -->
    <!--parameter name="MTOMBufferSize" locked="false">10</parameter-->
    <!--parameter name="MTOMMaxBuffers" locked="false">1000</parameter-->
    <!--parameter name="EnableMTOMServiceCallback" locked="false">true</parameter-->
    <!--parameter name="attachmentDIR" locked="false">/path/to/the/attachment/caching/dir/</parameter-->    
    <!--parameter name="MTOMCachingCallback" locked="false">/path/to/the/caching_callback</parameter-->
    <!--parameter name="MTOMSendingCallback" locked="false">/path/to/the/sending_callback</parameter-->


    <!-- Enable REST -->
    <parameter name="enableREST" locked="false">true</parameter>


    <!-- Uncomment following to persist op_ctx, useful with RM -->
    <!--parameter name="persistOperationContext" locked="false">true</parameter-->


    <!--if you want to extract the service archive file and work with that please uncomment this-->
    <!--else , it wont extract archive file or does not take into consideration if someone drop-->
    <!--exploded directory into /service directory-->
    <!--<parameter name="extractServiceArchive" locked="false">true</parameter>-->




    <!-- ================================================= -->
    <!-- Message Receivers -->
    <!-- ================================================= -->
    <!-- This is the Deafult Message Receiver for the Request Response style Operations -->
    <!--messageReceiver mep="INOUT" class="axis2_receivers"/-->


  
    <!-- ================================================= -->
    <!-- Transport Ins -->
    <!-- ================================================= -->
  
    <transportReceiver name="http" class="axis2_http_receiver">
        <parameter name="port" locked="false">6060</parameter>
        <parameter name="exposeHeaders" locked="true">false</parameter>
    </transportReceiver>
  
    <transportReceiver name="https" class="axis2_http_receiver">
        <parameter name="port" locked="false">6060</parameter>
        <parameter name="exposeHeaders" locked="true">false</parameter>
    </transportReceiver>
  
    <!--transportReceiver name="tcp" class="axis2_tcp_receiver">
        <parameter name="port" locked="false">6060</parameter>
    </transportReceiver-->




    <!-- ================================================= -->
    <!-- Transport Outs -->
    <!-- ================================================= -->


    <transportSender name="http" class="axis2_http_sender">
        <parameter name="PROTOCOL" locked="false">HTTP/1.1</parameter>
        <parameter name="xml-declaration" insert="false"/>
        <!--parameter name="Transfer-Encoding">chunked</parameter-->
        <!--parameter name="HTTP-Authentication" username="" password="" locked="true"/-->
        <!--parameter name="PROXY" proxy_host="127.0.0.1" proxy_port="8080" proxy_username="" proxy_password="" locked="true"/-->
    </transportSender>


    <!-- Uncomment the following with appropriate parameters to enable the SSL transport sender.
         Also make sure that the appropriate transport receiver is enabled above.-->
    <transportSender name="https" class="axis2_http_sender">
        <parameter name="PROTOCOL" locked="false">HTTP/1.1</parameter>
        <parameter name="xml-declaration" insert="false"/>
    </transportSender>
    <parameter name="SERVER_CERT">C:\Program Files (x86)\SAP BusinessObjects\Data Services\ext\jre\lib\security\cer.cer</parameter>
    <parameter name="KEY_FILE">/path/to/client/certificate/chain/file</parameter>
    <parameter name="SSL_PASSPHRASE">passphrase</parameter>
    -->
		
    <!-- Uncomment this one with the appropriate papameters to enable the TCP transport Sender-->
    <!--transportSender name="tcp" class="axis2_tcp_sender">
        <parameter name="PROTOCOL" locked="false">TCP</parameter>
        <parameter name="xml-declaration" insert="false"/>
    </transportSender-->




    <!-- ================================================= -->
    <!-- Global Modules  -->
    <!-- ================================================= -->
    <!-- Comment this to disable Addressing -->
    <module ref="logging"/>
    <module ref="addressing"/>
    <!--module ref="rampart"/--> 






    <!--Configuring module , providing paramters for modules whether they refer or not-->
    <!--<moduleConfig name="addressing">-->
    <!--<parameter name="addressingPara" locked="false">N/A</parameter>-->
    <!--</moduleConfig>-->


    <!-- ================================================= -->
    <!-- Phases  -->
    <!-- ================================================= -->
    <phaseOrder type="inflow">
        <!-- System pre defined phases       -->
        <phase name="Transport"/>
        <phase name="PreDispatch"/>
        <phase name="Dispatch"/>
        <phase name="PostDispatch"/>
        <!--phase name="Security"/-->
        <!-- End system pre defined phases       -->
        <!-- After PostDispatch phase, module or service author can add any phase as required  -->
        <!-- User defined phases could be added here -->
        <!--phase name="userphase1"/-->
    </phaseOrder>
    <phaseOrder type="outflow">
        <!-- User defined phases could be added here -->
        <!--phase name="userphase1"/-->
        <!--system predefined phase-->
        <phase name="MessageOut"/>
        <!--phase name="Security"/-->
    </phaseOrder>
    <phaseOrder type="INfaultflow">
        <!-- User defined phases could be added here -->
        <!--phase name="userphase1"/-->
    </phaseOrder>
    <phaseOrder type="Outfaultflow">
        <!-- User defined phases could be added here -->
        <!--phase name="userphase1"/-->
        <phase name="MessageOut"/>
    </phaseOrder>
</axisconfig>


10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

avatar image
Former Member Dec 13, 2017 at 03:27 PM
0

Hi, I am having the same issue. can you please let me know how you resolved the issue.

Thanks,

Share
10 |10000 characters needed characters left characters exceeded