Skip to Content
0
Former Member
Feb 24, 2007 at 11:28 AM

Homogeneous system copy

17 Views

Hi ,

I have performed a homogeneous system copy Via ORACLE BACKUP & RESTORE of my SAP system.After restoring DB, I am able to connect to DB .But SAP is not coming up. R3trans return code 0000.

<b>My source system</b>:

SAP 4.7 2.0 kERNEL REL:620,ORACLE 9.2.0.4,WIN 2003

Target system configuration is same as source system (including DIRECTORY STRUCTURE). I have tried all the points mentioned in <b>SAPNOTES:4000241,50088</b>.Recreated user and tables.

The only difference i find is : while installing SAP <b>in TARGET system</b>, I named <b>SAP schema as C11</b> (my DBSID=C11) but in <b>SOURCE SYSTEM</b>, the <b>schema is BBC.(DBSID=C11</b>). So, i think the work processes are trying to connect to C11 schema instead of BBC schema. I have set the environmental variables as per the notes. In SAPUSER table, I gave the userid as SAPBBC.According to the WP trace, OPS$ user connected succesfully to DB, got SAPBBC user's password from SAPUSER table but is failing to connect to DB . DB is up and running. <i><b>Iam able to connect to DB manually as SAPBBC using the same password given in SAPUSER table.</b></i>

DEV_W0 trace:

-


trc file: "dev_w0", trc level: 1, release: "620"

-


  • ACTIVE TRACE LEVEL 1

  • ACTIVE TRACE COMPONENTS all, M

B

B Sat Feb 24 11:22:02 2007

B create_con (con_name=R/3)

B Loading DB library 'D:\usr\sap\c11\SYS\exe\run\dboraslib.dll' ...

B Library 'D:\usr\sap\c11\SYS\exe\run\dboraslib.dll' loaded

B Version of 'D:\usr\sap\c11\SYS\exe\run\dboraslib.dll' is "620.02", patchlevel (0.876)

B New connection 0 created

M systemid 560 (PC with Windows NT)

M relno 6200

M patchlevel 0

M patchno 1750

M intno 20020600

M make: multithreaded, ASCII

M pid 10112

M

M ***LOG Q0Q=> tskh_init, WPStart (Workproc 0 10112) [dpxxdisp.c 1088]

I MtxInit: -2 0 0

M DpShMCreate: sizeof(wp_adm) 6080 (760)

M DpShMCreate: sizeof(tm_adm) 1835536 (9132)

M DpShMCreate: sizeof(wp_ca_adm) 18000 (60)

M DpShMCreate: sizeof(appc_ca_adm) 6000 (60)

M DpShMCreate: sizeof(comm_adm) 192000 (384)

M DpShMCreate: sizeof(wall_adm) (22440/34344/56/100)

M DpShMCreate: SHM_DP_ADM_KEY (addr: 038E0040, size: 2116120)

M DpShMCreate: allocated sys_adm at 038E0040

M DpShMCreate: allocated wp_adm at 038E0678

M DpShMCreate: allocated tm_adm_list at 038E1E38

M DpShMCreate: allocated tm_adm at 038E1E60

M DpShMCreate: allocated wp_ca_adm at 03AA2070

M DpShMCreate: allocated appc_ca_adm at 03AA66C0

M DpShMCreate: allocated comm_adm_list at 03AA7E30

M DpShMCreate: allocated comm_adm at 03AA7E48

M DpShMCreate: allocated ca_info at 03AD6C48

M DpShMCreate: allocated wall_adm at 03AD6C50

X EmInit: MmSetImplementation( 2 ).

X <ES> client 0 initializing ....

X Using implementation std

M <EsNT> Memory Reset enabled as NT default

X ES initialized.

M calling db_connect ...

C Got ORACLE_HOME=D:\oracle\ora92 from environment

C Client NLS settings: AMERICAN_AMERICA.WE8DEC

C Logon as OPS$-user to get SAPBBC's password

C Connecting as /@c11 on connection 0 ...

C Attaching to DB Server c11 (con_hdl=0,svchp=0370CBCC,svrhp=068849F4)

C Starting user session (con_hdl=0,svchp=0370CBCC,srvhp=068849F4,usrhp=0688D1CC)

C *** ERROR => OCI-call 'OCISessionBegin' failed: rc = 1017

[dboci.c 3733]

C *** ERROR => CONNECT failed with sql error '1017'

[dboci.c 9643]

C Try to connect with default password

C Connecting as SAPBBC/<pwd>@c11 on connection 0 ...

C Starting user session (con_hdl=0,svchp=0370CBCC,srvhp=068849F4,usrhp=0688D1CC)

C *** ERROR => OCI-call 'OCISessionBegin' failed: rc = 1017

[dboci.c 3733]

C *** ERROR => CONNECT failed with sql error '1017'

[dboci.c 9643]

B ***LOG BY2=> sql error 1017 performing CON [dbsh#2 @ 962] [dbsh 0962 ]

B ***LOG BY0=> ORA-01017: invalid username/password; logon denied [dbsh#2 @ 962] [dbsh 0962 ]

B ***LOG BY2=> sql error 1017 performing CON [dblink#1 @ 419] [dblink 0419 ]

B ***LOG BY0=> ORA-01017: invalid username/password; logon denied [dblink#1 @ 419] [dblink 0419 ]

M ***LOG R19=> tskh_init, db_connect ( DB-Connect 000256) [thxxhead.c 1197]

M in_ThErrHandle: 1

M *** ERROR => tskh_init: db_connect (step 1, th_errno 13, action 3, level 1) [thxxhead.c 8834]

M

M Info for wp 0

M

M stat = 4

M reqtype = 1

M rq_info = 0

M act_reqtype = -1

M tid = -1

M mode = 255

M len = -1

M rq_id = -1

M rq_source = 255

M last_tid = 0

M last_mode = 0

M int_checked_resource(RFC) = 0

M ext_checked_resource(RFC) = 0

M int_checked_resource(HTTP) = 0

M ext_checked_resource(HTTP) = 0

M report = > <

M action = 0

M tab_name = > <

M

M *****************************************************************************

M *

M * LOCATION SAP-Server param_c11_09 on host param (wp 0)

M * ERROR tskh_init: db_connect

M *

M * TIME Sat Feb 24 11:22:02 2007

M * RELEASE 620

M * COMPONENT Taskhandler

M * VERSION 1

M * RC 13

M * MODULE thxxhead.c

M * LINE 8979

M * COUNTER 1

M *

M *****************************************************************************

M

M Entering TH_CALLHOOKS

M ThCallHooks: call hook >ThrSaveSPAFields< for event BEFORE_DUMP

M *** ERROR => ThrSaveSPAFields: no valid thr_wpadm [thxxrun1.c 672]

M *** ERROR => ThCallHooks: event handler ThrSaveSPAFields for event BEFORE_DUMP failed [thxxtool3.c 241]

M Entering ThSetStatError

M Entering ThReadDetachMode

M call ThrShutDown (1)...

M ***LOG Q02=> wp_halt, WPStop (Workproc 0 10112) [dpnttool.c 356]