Skip to Content
0

SYSTEM user is unable to grant Analytic Privilege to user

May 22, 2017 at 04:17 PM

594

avatar image

Hi all,

I have just created a HANA view from a DSO in a BW system on HANA. The view is created with analytic privileges set by default.

When I try to preview the data in the view I get an authorisation error:

>> Error: SAP DBTech JDBC: [258]: insufficient privilege

Running an authorisation trace on my user I can see the following error message in the trace file:

>> User MWHEATON is not authorized to access _SYS_BIC.system-local.bw.bw2hana/ZMARKDSO because he is missing any structured privileges applicable to that object

I have found what looks like a system-generated analytic privilege for the view, but when I log in as the SYSTEM user and try to assign that analytic privilege to my user (MWHEATON) I get the following error message:

>> "Could not modify user 'MWHEATON'. Could not grant privilege bw2hana/SAPABAP1_ZMARKDSO You are not authorized to perform the required actions"

The trace output for this activity looks like this:

>> insufficient privilege: Not authorized;;;;0;;9:HDBStudio;0;6:SYSTEM;

#grant STRUCTURED PRIVILEGE "bw2hana/SAPABAP1_ZMARKDSO" to MWHEATON

Now, I can get round this problem by just switching off the analytic privileges on the view, and that allows me to see the data just fine. But I think I am missing something big here so I would like to try to resolve the underlying issue of why I can't get the SYSTSEM user to grant the generated analytic privilege to my user.

All ideas & suggestions welcome.

Cheers,

Mark

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

avatar image
Former Member Aug 09, 2017 at 06:01 AM
0

Hello Mark,

We are also facing the same issue while providing analytic privilege it's giving me same error using SYSTEM user.

Any idea how to resolve this.

Regards,

Rajan Patwardhan

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Rajan,

thanks for your response. I was unable to resolve the problem so I just switched off analytic privileges on the view.

Mark

0