Skip to Content
0

ARTMAS06 Inbound IDOC issue

May 22, 2017 at 01:40 PM

85

avatar image

Hi, I’m getting some contradictions for inbound ARTMAS06 IDOC,

First Message: No entry in key field for consumption value for article (Message no. MG514)

Entered key values for consumption in respective segments

E1BPE1MPOPRT , E1BPE1MPOPRTX , E1BPE1MPRWRT , E1BPE1MVEGRT , E1BPE1MVEURT

If I miss any of the above segments, the above error repeats. After processing the IDOC, I'm getting the following

Second Message: No consumption values possible for period 00000000 (Message no. M3040)

Also, SAP forces me to add all the segments in the system which I don’t require in creating the article. Kindly give me the work around.

Thanks,

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Jürgen L
May 22, 2017 at 04:54 PM
0

Before you can have consumption values you have to have a period indicator in your material master - in a industry ERP system is this the period indicator in MRP3 view (table MARC) and is either Month, week, or day.

SAP article master has some mandatory structures, without them you can't create or update an article, e.g. basis data, descriptions.

The easiest way to know how an Idoc should be maintained is by setting up an ALE distribution and then create a material master manually with just the data that you need and send this material by ALE, then check in BD87 how the Idoc looks like and which fields it has .

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Please check below my answer

0
Hardik Mehta May 24, 2017 at 05:20 PM
0

Hi,

I have put the values in E1BPE1MARCRT-PERIOD_IND field, but still I'm getting same result. Even I'm populating FORE_MODEL = 0 (No Forecast/no external model) or N to get out of this issue.

This article is external procurement, finished product for which we do not want any forecasting details. If I put only the key values in E1BPE1MPOPRT , E1BPE1MPOPRTX , E1BPE1MPRWRT , E1BPE1MVEGRT , E1BPE1MVEURT segments, still I'm getting the same error. If I don't put it in, I'm getting "No key fields" error.

Please suggest.

Thanks,

Show 1 Share
10 |10000 characters needed characters left characters exceeded

these segments are not enough to create or change a material: E1BPE1MPOPRT , E1BPE1MPOPRTX , E1BPE1MPRWRT , E1BPE1MVEGRT , E1BPE1MVEURT segments

you need MARA at least MARA and MAKT along with them.

Better explain what you want, if you do not need any of those segments, then just delete it from your structure (assuming that you are experimenting with WE19)

0