Skip to Content
avatar image
Former Member

Unable to connect Xi server through URL

Hi guys,

I am facing this problem from last 2 days .i am able to login to my XI server through Gui quite easily and every transaction is running fine ..but when i m trying to connect through Url : http://aks22:50000/rep/start/index.jsp then either its connecting very slow or sometimes not connecting ...i had already restarted the Xi server and reboot machine few times and also j2ee server through T-code "smicm" ..but issue is not resolved ..can anyone help me out ...

Thanks in advance.

Rohit Goswami

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Feb 23, 2007 at 08:25 AM

    Hi Rohit,

    <i>either its connecting very slow or sometimes not connecting ..</i> - can you just ask your basis guys to see the startup log of j2ee engine of your XI server...is there any error in it or not.....if there is any error, then you will have to completely restart your XI server again......

    if there is no error in J2EE engine, then go to SXMB_MONI, see how many msgs are in queue for processing.......just first process all these msgs and till the time all your msgs are not processed - dont give any source file to xi......when all your msgs are successfully processed, then try opening the URL of IB......then i think you may easily log into IB.

    Thanks,

    Rajeev Gupta

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 23, 2007 at 10:58 AM

    thanks rajiv,

    but i m still trying and gain i had just rebooted the server and restart the server but the problem is still the same its taking too much time to open and also sometimes i am getting an error in integration builder and the strange thing is every time the error is differnet ...last time got the error java web start "unexpected error"...unable to launch integration builder...An error occurred while launching/running the application.

    Title: Integration Builder

    Vendor: SAP AG

    Category: Unexpected Error

    Unexpected exception: java.lang.NullPointerException....

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Rohit

      Can you check whether the j2ee engine is up and running?

      You can also try restarting the engine from SMICM and then check for logs.

      Regards

      Sunita

  • avatar image
    Former Member
    Feb 23, 2007 at 11:01 AM

    and also in exception report the details is ...

    ava.lang.NullPointerException

    at com.sap.plaf.frog.FrogScrollPaneUI$1.propertyChange(FrogScrollPaneUI.java:113)

    at java.beans.PropertyChangeSupport.firePropertyChange(Unknown Source)

    at java.beans.PropertyChangeSupport.firePropertyChange(Unknown Source)

    at java.awt.Component.firePropertyChange(Unknown Source)

    at javax.swing.JScrollPane.setHorizontalScrollBar(Unknown Source)

    at javax.swing.plaf.basic.BasicComboPopup.createScroller(Unknown Source)

    at javax.swing.plaf.basic.BasicComboPopup.<init>(Unknown Source)

    at com.sap.plaf.frog.FrogComboPopup.<init>(FrogComboPopup.java:34)

    at com.sap.plaf.frog.FrogComboBoxUI.createPopup(FrogComboBoxUI.java:185)

    at javax.swing.plaf.basic.BasicComboBoxUI.installUI(Unknown Source)

    at com.sap.plaf.frog.FrogComboBoxUI.installUI(FrogComboBoxUI.java:115)

    at javax.swing.JComponent.setUI(Unknown Source)

    at javax.swing.JComboBox.setUI(Unknown Source)

    at javax.swing.JComboBox.updateUI(Unknown Source)

    at javax.swing.JComboBox.init(Unknown Source)

    at javax.swing.JComboBox.<init>(Unknown Source)

    at com.sap.aii.utilxi.swing.toolkit.JComboBoxExt.<init>(JComboBoxExt.java:22)

    at com.sap.aii.utilxi.swing.toolkit.Guitilities.createComboBox(Guitilities.java:987)

    at com.sap.aii.ib.gui.personalization.CommonResource.getLoginLanguageBox(CommonResource.java:153)

    at com.sap.aii.ib.gui.login.SplashLoginFrame.<init>(SplashLoginFrame.java:166)

    at com.sap.aii.ib.gui.login.SplashLoginImpl.doSplashLogin(SplashLoginImpl.java:96)

    at com.sap.aii.ibrep.gui.appl.ApplicationImpl.main(ApplicationImpl.java:624)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

    at java.lang.reflect.Method.invoke(Unknown Source)

    at com.sun.javaws.Launcher.executeApplication(Unknown Source)

    at com.sun.javaws.Launcher.executeMainClass(Unknown Source)

    at com.sun.javaws.Launcher.continueLaunch(Unknown Source)

    at com.sun.javaws.Launcher.handleApplicationDesc(Unknown Source)

    at com.sun.javaws.Launcher.handleLaunchFile(Unknown Source)

    at com.sun.javaws.Launcher.run(Unknown Source)

    at java.lang.Thread.run(Unknown Source)

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Rohit,

      i think your XI J2EE engine is not starting properly....ask your basis guys why this is happening - they can tell you this thing ..........

      Thanks,

      Rajeev Gupta

      Message was edited by:

      RAJEEV GUPTA

  • Feb 26, 2007 at 10:55 AM

    Hi Rohit,

    from the Configuration Manager or J2EE Engine Visual Administrator check that you have enough Application Threads available,

    <i>e.g.,</i>

    J2EE VA

    <b>Global Configuration

    -> Server

    -> Kernel

    -> Application Thread Manager</b>

    ensure the MaxThreadCount property is set to >= 300

    Restart the J2EE Engine

    If the problem persists after this try starting the Integration Builder Applications

    from the J2EE Visual Administrator

    i.e.,

    <b> J2EE VA

    Cluster

    -> Server

    -> Deploy

    -> Select the 'Application' radio button</b>

    if any

    sap.com/com.sap.aii*>

    or

    sap.com/com.sap.xi*>

    applications,

    e.g.

    com.sap.aii.af

    com.sap.aii.af.adapter.caller

    com.sap.aii.af.app

    com.sap.aii.af.cpa.app

    com.sap.xi.services</i>

    are stopped (i.e., red 'X' instead of blue tick) then use the options on the right hand

    side of the screen to start the applications.

    Regards

    Kenny

    Add comment
    10|10000 characters needed characters exceeded