Skip to Content
1

Changes history tab not working

May 21, 2017 at 12:19 PM

75

avatar image

Dear Experts,

I have added ChangeDocumentsChangeDocuments_EC reuse component , in my custombo. But the changes are not displaying in changes tab.

Below are the steps I did:

  1. In the OIF, added ChangeDocuments_EC reuse component.
  2. Created an outport and added the parameter ECORootNodeID (this is binded to nodeid)
  3. On the changes tab, in bind added navigation and selected the outport and inport field and is displayed in the Bound parameters
  4. Added click eventhandler which has the type as fire outport created above.
  5. Added configuration parameters in changedocuments_ec properties. Both BO and Eco name and namesapace are addde same.
  6. Save and Activated.
  7. Deployed the business configuration.

After doing all the above steps , Changes tab is displayed with controls,but on click of Go button , no data is displayed though I made changes to BO.

Please let me know what Iam missing here and how to resolve this issue.

Thanks,

Resmi

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Laura Edelman Jun 19, 2017 at 02:15 PM
0

Hi Resmi,

I ran into the same issue where my configuration followed the guides to the letter, and the screen was still either crashing or returning no data when I ran the query.

Although it's not an ideal solution, I did find that reverting the OIF back to the version before I started making any change history adjustments, then adding them all back 100% correctly resulted in a working change log. I suspect that something caused a conflict when I was exploring the set-up, and the error persisted even after the configuration was fixed.

The 1702 documentation has mostly the same instructions, but this guide was the one I used when I successfully re-added the change log (and it has screenshots, too).

Cheers,

Laura

Share
10 |10000 characters needed characters left characters exceeded