Skip to Content
avatar image
Former Member

configuring TPPARAM

Hi everyone

I am trying to configure TPPARAM file...TPPARAM file in my computer

is named as tpparam_instDEV

contents in my TPPARAM file :

****************************************

TRANSDIR =
development\sapmnt\trans

DEV/DBHOST =development

DEV/DBNAME =DEV

DEV/DBTYPE =ora

DEV/SYSTEM_PF =
development\sapmnt\DEV\SYS\profile\DEFAULT.PFL

DEV/MSPORT =3601

*****************************************

i tried changing the transdir= path where my tp file is located

and when i try testing the TP connection.

C:\ tp connect dev ( i get an error )

**************************************************

Microsoft Windows 2000 [Version 5.00.2195]

(C) Copyright 1985-2000 Microsoft Corp.

C:\Documents and Settings\devadm>tp connect dev

This is tp version 340.15.06 (release 640, unicode enabled)

E-TPSETTINGS could not be opened.

EXIT

ERROR: System : Parameter SAPEVTPATH not set. Batch jobs cannot be started.

Error in TPSETTINGS: transdir not set.

tp returncode summary:

TOOLS: Highest return code of single steps was: 0

ERRORS: Highest tp internal error was: 0208

tp finished with return code: 208

meaning:

error in transportprofil (param missing, unknown,...)

C:\Documents and Settings\devadm>

**********************************************************

can anyone help me configuing this file correctly.

Thank you

Kiran Kumar

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • Feb 21, 2007 at 05:14 PM

    try this:

    cd \usr\sap\trans\bin

    tp connect DEV

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 21, 2007 at 08:04 PM

    configuring tp with tpparam is quite old fashioned and imo not supported any more...correct me if i'm wrong...use transaction STMS instead and your parameter file will be configured accordingly...

    > cd \usr\sap\trans\bin

    > tp connect <SID> <b>pf=TP_DOMAIN_<SID of transport domain system>.PFL</b>

    GreetZ, AH

    Add comment
    10|10000 characters needed characters exceeded

    • a) the tp environment is not configured through TPPARAM anymore but through transaction STMS...so this would be the right way to configure your tp

      b) seems ok...return code is 0000, which means that a connect is possible and everything's OK!

      c) you should patch your tp executable since yours has a 10/2004 date...a newer version can be donwloaded from sapnet...

      GreetZ, AH

  • avatar image
    Former Member
    Feb 26, 2007 at 03:07 PM

    hello everyone..

    I thank everyone @ SDN who have been so co-operative in answering my questions.

    I would like to thank especially Peter and Andreas..

    Well what i have understood is that my TPPARAM was configured fine

    but i was testing it wrong..

    Thank you one and all

    Kiran Kumar..

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Mar 01, 2007 at 03:06 PM

    I thank everyone who posted their comments

    on this thread..

    Everyone comments were quite helpful and i am

    happy learning new things..

    Thank you.

    Kiran Kumar

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Kiran,

      I suppose that you solve this issue!! Can you please help me with the same one?

      thanks,

      Best Regards

      Pedro