Skip to Content

Error ICM_HTTP_CONNECTION_FAILED

Hi,

in our system I have problems with http-request to a given url. I test it with report rswf_test_http and i. e. url http://www.google.de.

In client 000 the report works fine, in client 800 it produce the error ICM_HTTP_CONNECTION_FAILED, error-code = 400.

Has anybody an idea to solve this problem?

Thanks

Herbert Soethe

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Feb 19, 2007 at 11:12 AM

    Hi,

    Check this blog:

    /people/krishna.moorthyp/blog/2006/07/23/http-errors-in-xi

    Thanks,

    Rajeev Gupta

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 19, 2007 at 02:38 PM

    Hi,

    Can you pleae check the following:

    • Check the outbound binding of the message in transaction SXMB_MONI.

    • Find the Adapter Engine the message is sent to in the tag SAP:AdapterEngineName --> af.<sid>.<host>

    • Call transaction SXI_CACHE and choose Goto --> AE Cache

    • Check the URL for the Adapter Engine, for example

    https://server:J2EE-port/MessagingSystem/receive/AFW/XI

    • Try to execute the URL in the browser using the user XIISUSER/PIISUSER(name as set during installation).

    • --> Check the error you get:

    o Page cannot be displayed, cannot find server --> server:port not accessible

    o HTTP 401 --> unauthorized

    o HTTP 403 -->forbidden

    o HTTP 500 --> internal Server Error

    If you have the error:

    <b>a. Page cannot be displayed, cannot find server :</b>

    If HTTPS is used but you would like to use HTTP, SSL is probably activated by mistake.

    To deactivate SSL for XI messaging, do the following:

    o Open the exchange profile:

    http://server:port/exchangeProfile

    o Delete the messaging value in the com.sap.aii.connect.secure_connections parameter in the Connections section.

    o Save it.

    o Restart the J2EE server to activate the change.

    o Delete the Adapter Engine cache in transaction SXI_CACHE Goto --> Cache.

    o Restart the message.

    <b>b. Page cannot be displayed, cannot find server</b>

    If HTTPS is used and you really want to use HTTPS:

    o Check and correct the SSL configuration for the ABAP and the J2EE side of the system.

    <b>c. HTTP 401</b>

    o User XIISUSER/PIISUSER uses a wrong password.

    o Check the exchange profile and transaction SU01; reset the password.

    o Restart the J2EE Engine to activate changes in the exchange profile.

    o Delete the Adapter Engine cache in transaction SXI_CACHE Goto --> Cache.

    o Restart the message.

    <b>d. HTTP 403</b>

    o User XIISUSER/PIISUSER has no authorization to send messages to the messaging system.

    o This is caused by a deployment error of the J2EE Engine.

    o Undeploy the component com.sap.aii.af.ms.app and redeploy SAPXIAF*.sca.

    o Restart the message.

    <b>e. HTTP 500</b>

    o Internal error in J2EE

    o Check SAP Note 807000 - Http requests are not fully read after timeout

    <b>f. HTTP 503</b>

    J2EE application com.sap.aii.af.ms.app not active

    o Try to (re)start the application using the Visual Administrator

    Choose Server --> Services --> Deploy --> View on Application or restart the J2EE engine.

    ---Satish

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Feb 19, 2007 at 07:11 PM

    Make sure that you have specified HTTP port is correctly in communication channel. To check the port use T-code SMICM >Goto >Services.

    Message was edited by:

    rakesh Patel

    Add comment
    10|10000 characters needed characters exceeded

  • Feb 19, 2007 at 07:17 PM

    Hi,

    1) Can you Check whether SLD is active, Try to re start the SLD ,

    This might help you

    /people/sugree.phatanapherom/blog/2005/08/14/configuring-sld-in-sneak-preview-sap-netweaver-04-sneak

    2) Check is it time out error, ( Data unable to fetch due to time out error )

    3) Go tCode- ST22 and check for the DUMP for more information.

    Regards

    Agasthuri Doss

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 22, 2007 at 11:26 AM

    An incorrect line in table pproxy_g was the reason for error.

    Add comment
    10|10000 characters needed characters exceeded