Skip to Content
avatar image
Former Member

BODS 4.2 failing when loading larger than 2gb flat file to S3 location

Hi Community

I have a customer that is creating a job to extract data from an oracle db to a flat file (CSV) on AWS S3.

The job is simple, one source, one query with no transform or filter, and the target which is loaded as a file location in bods designer.

When they load a file through bods, the largest that they can successfully load is 1.94gb. the next smallest that they have tried is 2.8gb which simply does not appear in the S3 folder. There is no error on the DS job, it all completes successfully. so the guess is anything larger than 2gb is causing issues. But when they manually load a file that is larger than 2gb it goes in fine (4gb has been tried and successfully loaded manually).

The whole environment is a dev environment and all components (CMC, Job Server, DS designer etc...) installed on the same box and hard disk. The hard disk is NTFS so the FAT limit of 2gb file size limit is not a likely culprit.

Does anyone have some ideas on what might be causing this behaviour?

Kind Regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

0 Answers