Skip to Content
0

Condition exclusion not working

May 18, 2017 at 09:30 AM

97

avatar image

Dear Experts,

I have a Pricing procedure where condition exclusion is configured, IF ZCPM exists then all abse conditions shhould be inactive

.

Once i create order and see item conditions there ZCPM is inactive and ZLS2 is active. But If i go to header Condtions and then come back to Item conditions then ZCPM is active and ZLS2 is active.

This is working fine for other SALES ORG CUSTOMER..

Please help.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

G Lakshmipathi
May 18, 2017 at 10:10 AM
0

This seems to be not a standard but due to some customized user exit or routine. Did you check with your ABAP team?

Share
10 |10000 characters needed characters left characters exceeded
Satyanarayan Panigrahi May 18, 2017 at 10:36 AM
0

I am from Dev team and was trying to debug the Pricing FM. However have not yet got any success.

Share
10 |10000 characters needed characters left characters exceeded
Patrick Bazan May 18, 2017 at 12:26 PM
0

Hello,

are you using the kobed and kobev routines in the calculation?
You can check there the status of your condition and if necessary you can deactivate your conditions when

ZCPM is active.

Otherwise implement your code into user exit include

RV61AFZB form USEREXIT_XKOMV_BEWERTEN_END

Something like this with field xkomv-kinak:

 LOOP AT xkomv ASSIGNING <wa_xkomv> WHERE kschl = 'ZXXX'.
 <wa_xkomv>-kmanu = 'D'. "not manually editable
 ENDLOOP.

BR

Share
10 |10000 characters needed characters left characters exceeded
Patrick Bazan May 22, 2017 at 11:52 AM
0

Hello Satyanarayan,

is your topic solved? Please give Feedback.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Patrick,

issue resolved by functional team.

0