Skip to Content
0

HCI Deployment configuration Sender/Reciever "employee central to erp employee data"

May 17, 2017 at 06:27 PM

786

avatar image
Former Member

Dear Experts,

Kindly we are integrating EC(Successfactor) to ERP having HCI as middleware. Please help to configure artifact in HCI with sender and reciever information.

Artifact name: Employee central to ERP employee data.

Attached screenshot for the information we are looking for.

P.S: We have already referred to document which is available with the artifact along cloud platform document and online help. Could not find the exact details on the information to go on the fields.

Thank you.

Regards,

Harish

sender.jpg (36.7 kB)
receiver.jpg (59.5 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Sriprasad Shivaram Bhat May 21, 2017 at 04:12 PM
2

Hello Harish,

Please find the below details.

Navigate to required IFlow of your Integration Project and follow below steps.

Step1:

[ Relevant Help document of the Integration Project can be found by clicking Documents ( next to highlighted tab )and following the link provided there ]

Step2:

1) Click on the receiver( Since you want to configure receiver channel)

2) Select the relevant channel( In your case its channel connecting to SF ).

3) Enter the address( you have to enter API Server name of the SF instance you want to connect ).You can search for the relevant API server in below OData API Guide[ Refer Page No#16 ]
https://help.sap.com/doc/74597e67f54d4f448252bad4c2b601c9/PRODUCTION/en-US/SF_HCM_OData_API_REF_en.pdf

4) Enter the credential name( which is Security artifact having User Name,Password and SF Company ID).

5) Save the changes( you can change rest of the parameter,for details of those refer the guide provided by Gayathri )

6) Deploy the updated IFlow.

Regards,

Sriprasad Shivaram Bhat


Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Sriprasad,

Thank you so much. It helped to fix the problem. However i'm getting a different exception now. Is the problem related to successfactors or is something missing at HCI end. I have maintained everything as described by you and also tested successfully the API url from https://sfapitoolsflms.hana.ondemand.com/SFIntegration/sfapitools.jsp

Message processing failed.

com.sap.it.rt.adapter.sfsf.wsclient.SfsfWsClientFaultException: Problem during invoking SuccessFactors Web service. SOAP faultCode ns2:Server, faultString Invalid SFAPI session!, errorCode INVALID_SESSION, errorMessage: Invalid SFAPI session!, cause: org.apache.cxf.binding.soap.SoapFault: Invalid SFAPI session!

Thank a lot for your kind help.

Regards,

Harish

exception.jpg (64.4 kB)
0
Former Member
Former Member

Dear Sriprasad,

Just to update, the above mentioned issue is occurring occasionally. Now SFAPI is bring in data, but unable to push the data to ERP.

When I run the integration, employee information is returned from SFAPI but failing with the below error.

In the address section of sender, I have maintained the below URL from web service access URL from SOAMANAGER replacing the host name and port configured as internal(Host and port) from cloud connector.

Below is the error which is occurring whenever i'm running. Could you please advise what could be the reason please.

error1.jpg (65.3 kB)
error2.jpg (48.4 kB)
error1.jpg (65.3 kB)
0
Gayathri Narayana
May 18, 2017 at 10:53 AM
1

Hi,

On the sender side, use the SuccessFactors adapter ( https://help.sap.com/viewer/0556956740fd479d88d61c4fbb5a803b/Cloud/en-US/28b29d6b50d6419eadb15e59b9462da4.html) . You could refer to some of the standard integration content on EC to ERP integration as a reference if you have more questions on which adapters to use and the configurations (e.g. https://cloudintegration.hana.ondemand.com/#/shell/discover/contentpackage/SuccessFactorsEmployeeCentraltoERPEmployeeTimeforPayroll?tab=1)

hope this helps,

Gayathri

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Gayathri,

Thank you so much the use full links. Could you please confirm what needs to be entered in the Address of Sender. I tried multiple options. It gives the error shown below.

javax.xml.ws.WebServiceException: Could not send Message., cause: java.net.URISyntaxException: Illegal character in path at index 0: <SFSF_EC_Base_URL>/sfapi/v1/soap

Where can I maintain parameter <SFSF_EC_Base_URL> ? I couldnt find it anywhere in HCI tenant to configure the same.

Thanks,

Harish

0
Former Member

Hi Gayathri,

Thank you so much the use full links. Could you please confirm what needs to be entered in the Address of Sender. I tried multiple options. It gives the error shown below.

javax.xml.ws.WebServiceException: Could not send Message., cause: java.net.URISyntaxException: Illegal character in path at index 0: <SFSF_EC_Base_URL>/sfapi/v1/soap

Where can I maintain parameter <SFSF_EC_Base_URL> ? I couldnt find it anywhere in HCI tenant to configure the same.

Thanks,

Harish

0