Skip to Content

BOBJ 4.2 SP4 Upgrade CMC Error: NullPointerException: null object loaded from local variable 'enc'

Hello,

Seeing that BOBJ 4.2 SP4 was available on the Downloads site, I wanted to try out the new launchpad and other features, so I attempted to upgrade my recently patched 4.2 SP3 Patch 6 single server environment.

When I started the upgrade, it warned me that fixes would be removed if I continued the install. So I assumed SP3 Patch 6 has fixes SP4 base does not. I then uninstalled Patch 6 and installed SP4. At the end of the install it completed with warnings which I have seen similar before, it had trouble stopping the SIA and failed to deploy some DFO files.

I checked the packagestemp folder and found 3 DFO files (

BusinessObjects_Relation_DSL_Universe_DataSecurityOptions_dfo,

BusinessObjects_ICC_InformationControlCenter_dfo and

BusinessObjects_RecycleBinApplication_dfo). I moved them and their corresponding pin files into the XI 4.0\Packages folder to be processed, but they did not, so I assume the versions in the CMS DB are greater than the ones in the DFO. Probably left over from Patch 6 install.

I then tried to access the CMC and I get the following error:

HTTP Status 500 – Internal Server Error
Type Status Report

Message javax.servlet.ServletException: java.lang.Error: java.lang.NullPointerException: while trying to invoke the method java.lang.String.toCharArray() of a null object loaded from local variable 'enc'

Description The server encountered an unexpected condition that prevented it from fulfilling the request.

Apache Tomcat/8.5.13

in addition the BOE/BI launchpad logon screen DOES render; however, it will not take credentials. You enter valid credentials and click Log On and it just refreshes the logon screen, no errors, just a page refresh.

Looking at SAP Notes for similar issues, I tried to clear the work directory which didn't clear the error, then tried to re-deploy the web apps and finally clear the work directory again after deployment and none of those steps cleared the error.

I figure it has something to do with either a corrupted deployment, or left-over files from Patch install interfering with SP4 install. but I am guessing. Has anyone who has tried SP4 run into this?

Thanks,

Nathan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    May 23, 2017 at 10:29 AM

    Please refer to SAP Notes for more detail and development

    https://launchpad.support.sap.com/#/notes/2477634

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 17, 2017 at 12:11 PM

    Hi Nathan,

    Also excited with new SP4 features I've tried to update BOBJ SP3 patch 6. Got the same warnings during installation phase and after that.

    The environment doesn't work. The BI\CMC page is not able to load.

    Mariusz

    Add comment
    10|10000 characters needed characters exceeded

  • May 19, 2017 at 07:39 PM

    Had the same issue on my upgrade from Sp3 P6 to Sp4. But I also had Explorer.
    After upgrading explorer, clearing tomcat cache, IE cache and rebooting - everything started to work.

    One note - SP4 doesn't have fixes from Sp3 P6, so we do not recommend installing Sp4 on top of SP3 P6.
    Another, use machine name or FQDN in the URL's.

    Add comment
    10|10000 characters needed characters exceeded

    • Yea this install did have Explorer as well, but I downgraded both from Patch 6 to SP3 base then up to SP4 and still go the error. It was a test environment, did not try to upgrade prod yet, so just going to re-do SP3 Patch 6 on test to match the rest of the environment.

  • May 20, 2017 at 05:45 AM

    I've seen this as well. In my case I had to redeploy the war files + set SAP BI locales to English United states, otherwise they did not work. One customer who approved upgrade test env also keycode was missing (I saw this for very first time !!!!) , so check the server status, if all are disabled but running,t hen key also is the cause.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 23, 2017 at 05:42 AM

    Hello All,

    Don't update to BI 4.2 SP04 from BI4.2.3 Patch 6, However if you have updated then the workaround is to clear your browser cache and start working on BILP and CMC.

    There is no issue if we upgrade to 4.2 SP04 from 4.2 SP03 Patch 4 or Patch 5 or any of the previous version.

    Developer is working on it to get it fixed in one of the patches of BI 4.2 SP04.

    Regards, Pranav

    Add comment
    10|10000 characters needed characters exceeded