Skip to Content
avatar image
Former Member

Issue in 13.0.18, 13.0.19, and 13.0.20 - System.NullReferenceException at ShowNextPage()

I've discovered an issue that exists in the following 64bit run time versions:

13.0.18, 13.0.19, 13.0.20

This issue described here does not exist in run time versions prior to 13.0.18. I am experiencing this issue in a WinForms application developed in Visual Studio 2015, .NET 4.6.1, and the 13.0.20 components.

The issue described here presents itself at least on Windows 8.1, Windows 10, and Windows Server 2012 R2.

Issue Description:

When navigating through a report that contains a sub report in the detail section, navigating from page 10 to page 11 presents a Crystal Reports dialog stating:

"Object reference not set to an instance of an object."

I handle the exception to get more details via the CrystalDecisions.Windows.Forms.ExceptionEventHandler which provides me with the following call stack:

System.NullReferenceException: Object reference not set to an instance of an object.
at CrystalDecisions.CrystalReports.ViewerObjectModel.PageObject.CleanUpContent()
at CrystalDecisions.Windows.Forms.ReportDocumentBase.AddPage(PageObject page)
at CrystalDecisions.Windows.Forms.ReportDocumentBase.GetPage(Int32 pageN)
at CrystalDecisions.Windows.Forms.DocumentControl.ShowNthPage(Int32 PageNumber)
at CrystalDecisions.Windows.Forms.DocumentControl.ShowNextPage()
at CrystalDecisions.Windows.Forms.PageView.ShowNextPage()

The exception always occurs when navigating from page 10 to page 11. The sub report works perfectly fine within the report. If the report consists of less than 11 pages, then I am able to navigate to the end of the report with no issues.

I have confirmed that this is an issue in multiple reports, not just a single report. I have not found a workaround in code (including simply handling the exception) as it will not allow me to move past page 10. The only work around I have found in the report is by hiding the detail section which allows the report to navigate past page 10.

Please advise. Thank you.

Add comment
10|10000 characters needed characters exceeded

  • Former Member

    I get the exact same issue since upgrading from 2008 to 2013 SP20, just randomly loading pages using the tree - after 10 pages causes the same error as well as just clicking the next page button. However I've tried uninstalling it all and rolling back SP 17, but I still get the same error. :(

  • Get RSS Feed

7 Answers

  • Best Answer
    Jun 02, 2017 at 06:13 PM

    Hi Matt,

    I discovered it was a regression issue from the OLE Object resource issue update we did. Howard found the cause and fixed it.

    I downloaded the latest SP 21 build and tested it and it has been fixed. And it is related to the ondemand subreport, or it triggered the exception...

    So all good now..

    Thanks again for your patience

    Don

    Add comment
    10|10000 characters needed characters exceeded

    • I'm too having this issue using 13.0.20.2399 - as soon as you click on the 11th page (even on random ones in the list), it errors. Our clients are getting frustrated with it as they have to keep refreshing the report every 10 pages.

  • May 16, 2017 at 09:20 PM
    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 17, 2017 at 02:14 PM

    I reviewed that post and KBA - 2456246 doesn't seem to apply. My issue does not occur when drilling down on an on-demand sub report. The issue occurs when navigating from page 10 to page 11 on the main report. The reference registry path / key doesn't exist either:

    I have HKEY_CURRENT_USER\Software\SAP Business Objects\Crystal Reports for .NET Framework 4.0\Crystal Reports\DatabaseOptions but there is not a ViewOutOfPlaceSubreports key. I manually created one at that registry location but it did not have an affect.

    The option to change it to not be an on demand sub report isn't really an option. At the present, my only option is to have my customers remove the run times and revert back to 3.0.17 for my product to work properly.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 18, 2017 at 04:17 PM

    I have put together a very simple and quick video to demonstrate my specific issue, including how the sub report functions properly up until I attempt to go to page 11. This is consistent regardless of which report I load, and is always a problem with page 11.

    https://resources.rock-pond.com/sap_example.mp4

    Add comment
    10|10000 characters needed characters exceeded

  • May 25, 2017 at 12:53 PM

    Can you send me your report with saved data so I can test it?

    DEV just fixed a ondemand subreport issue so it may be related...

    Don

    Add comment
    10|10000 characters needed characters exceeded

  • May 30, 2017 at 04:54 PM

    Hi Matt,

    I was doing some testing for DEV on the OnDemand issue and discovered on his DEV Image when I get to page 11 I too was getting the Object not set... error.

    In my main test app I was getting it on the first page, it seems to be an event triggered in the WinForm Viewer. On his test app it showed up on the 11th page.

    I reported it to Howard yesterday but never heard back form him today...

    I still don't know if it's related but I don't think so now...

    The fix should be in SP 21.

    Thanks again

    Don

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 30, 2017 at 06:16 PM

    Thanks Don, if you need me to provide a sample report I can, but looks like you were able to replicate. Appreciate your attention to this!

    Add comment
    10|10000 characters needed characters exceeded