Skip to Content
0
Former Member
Feb 12, 2007 at 02:55 AM

RGZPFM stopped working after OS upgrade to V5R4 from V5R3

89 Views

Hi Guys,

We recently upgraded the operating system on our DEV & TEST boxes from V5R3 to V5R4.

Before the upgrade, we used to use the program ZRGZPFM attached in SAP note number: 84081 Reorganization of database tables (RGZPFM) for Re-Organizing the database tables weekly after the offline backup.

Now When we submit this program with the parameters &LIBRARY= R3<SID>DATA & &THRESHOLD =1000, we get the following Error:

CALL PGM(*LIBL/ZRGZPFM) PARM(R3BWTDATA 1000)

Object MBRLIST in QTEMP type *FILE not found.

Output file MBRLIST created in library QTEMP.

Member MBRLIST added to output file MBRLIST in library QTEMP.

16108 records added to member MBRLIST in file MBRLIST in QTEMP.

String constant beginning "QDBRGZ_R" not delimited.

The fast copy, or initialization can not be done.

Function check. CPF3169 unmonitored by ZRGZPFM at statement 1800,

instruction X'004C'.

CPF3169 received by ZRGZPFM at 1800. (C D I R)

When we do a F1 above on the "String constant beginning "QDBRGZ_R" not delimited", it shows us the following message:

Message ID . . . . . . : SQL0010 Severity . . . . . . . : 35

Message type . . . . . : Diagnostic

Date sent . . . . . . : 02/11/07 Time sent . . . . . . : 18:31:49

Message . . . . : String constant beginning "QDBRGZ_R" not delimited.

Cause . . . . . : The string delimiter is missing in the constant beginning

with "QDBRGZ_R". The string is treated as if it were delimited by the end

of the source file.

Recovery . . . : Delimit the string constant. Check for any missing or

extra quotation marks and apostrophes. These errors are likely to cause

other errors. Some statements may not have been processed as the result of

either missing or extra string delimiters. Precompile the program again.

I have tried recompiling and generating the object ZRGZPFM after the OS upgrade...Also deleted the duplicate ZRGZPFM object from the library ZRPLOBJ

and checked after the re-generation that the object is the latest generated version...

I have checked the File QDBR0001 in library QRECOVERY....which is generated during the Re-org...Also tried deleting the file and then restarting the job but to no success....

The same program was running perfectly till Last week in V5R3...and the same program is running perfectly in our PROD box...for which we are planning to upgrade the OS this coming weekend..., which I guess we may have to defer...if this is not resolved....

just running out of ideas altogether...Cud it be a PTF or something else...??

Thanks for all your help guys...

Abhi