Skip to Content
0

Problem retrieving data from SAP MII on HANA cloud/ Web IDE using Fiori app template

May 16, 2017 at 06:17 AM

205

avatar image

Hello ,

I am trying to fetch data from MII Xacute Query on Web IDE on HANA Cloud platform by taking a reference of a blog Creating Fiori App running on HANA Cloud Platform with data from SAP MII written by @Ruchir Batra. But I am not able to retrieve MII data.

I have completed the required prerequisite for the application to work:

1) I have successfully installed and configured HANA Cloud Connector. (HCC) 
2) I have successfully configured SAP MII system into HCC. Please have a look at the image below:

manifest.json looks like below:

The neo-app.json file looks like below:

The Master.view.xml file looks like below:

Now when I run the index.html file, I get below error:

I checked in Chrome development tools and I could observe two illuminatorOData call.

First one is successful:

while the other one which is actually fetching data from MII Query template is failing:

What am I doing wrong? Any hints/feedback/suggestions?

Thanks,

Soham

error-fiori.jpg (38.7 kB)
hcc-mii.jpg (74.2 kB)
neo-app.jpg (22.1 kB)
manifest.jpg (39.7 kB)
error-fiori.jpg (38.7 kB)
success-fiori.jpg (25.6 kB)
error-fiori-1.jpg (25.8 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Rajeev Kansal
May 25, 2017 at 04:06 AM
0

for web ide intgeration check following.

https://help.sap.com/saphelp_mii151sp03/helpdata/en/91/8a875792f25c08e10000000a441470/frameset.htm

this can be done only for MDO tables

Share
10 |10000 characters needed characters left characters exceeded